Запуск Varnish
В этом руководстве предполагается, что Varnish работает на Ubuntu, Debian, Red Hat Enterprise Linux или CentOS. Тем, кто работает на других платформах, возможно, придется приложить некоторые усилия для понимания. Раз вы на «странной» платформе, вы, вероятно, к этому привыкли. :-)
Убедитесь, что Varnish успешно установлен (следуя одной из процедур, описанных в разделе «Установка Varnish» выше).
При правильной установке вы запускаете Varnish с помощью service varnish start. Это запустит Varnish, если он еще не работает.
Теперь Varnish запущен. Давайте убедимся, что он работает правильно. Используйте свой браузер, чтобы перейти по ссылке http://127.0.0.1:6081/ (Замените IP-адрес на IP-адрес машины, на которой запущен Varnish). По умолчанию конфигурация будет пытаться перенаправлять запросы на веб-приложение, работающее на той же машине, что и Varnish. Varnish ожидает, что веб-приложение будет доступно по протоколу http на порту 8080.
Если веб-приложение недоступно по указанному адресу, Varnish выдаст ошибку. Varnish Cache очень консервативен в отношении сообщений об ошибках, поэтому при любых неполадках он будет выдавать стандартную ошибку «Ошибка 503 Сервис недоступен».
Возможно, у вас есть веб-приложение, работающее на другом порту или на другой машине. Давайте изменим конфигурацию, чтобы она указывала на работающий ресурс.
Запустите ваш любимый редактор и отредактируйте /etc/varnish/default.vcl. Большая часть его содержимого закомментирована, но есть некоторые некомментированные строки. Скорее всего, она будет выглядеть так:
vcl 4.0;
backend default {
.host = "127.0.0.1";
.port = "8080";
}
Мы изменим её, чтобы она указывала на работающий ресурс. Надеемся, что http://www.varnish-cache.org/ работает. Замените текст на:
vcl 4.0;
backend default {
.host = "www.varnish-cache.org";
.port = "80";
}
Теперь выполните service varnish reload для перезагрузки конфигурации Varnish. Если всё прошло успешно, посетите http://127.0.0.1:6081/ в вашем браузере, и вы должны увидеть список каталогов. Всё работает! Причина, по которой вы не видите официальный сайт Varnish, заключается в том, что ваш клиент не отправляет соответствующий Host заголовок в запросе, и в итоге отображается список файлов по умолчанию на машине, обычно обслуживающей http://www.varnish-cache.org/.
Copyright © 2006 Verdens Gang AS
Copyright © 2006–2020 Varnish Software AS
Licensed under the BSD-2-Clause License.
https://varnish-cache.org/docs/7.4/tutorial/starting_varnish.html