Spec-Zone.ru › Ansible 2.6

aci_domain_to_vlan_pool - Привязка домена к пулам VLAN (infra:RsVlanNs)

Новое в версии 2.5.

  • Описание
  • Параметры
  • Примечания
  • Примеры
  • Возвращаемые значения
  • Статус
  • Техническое обслуживание
    • Автор

Описание

  • Привязка домена к пулам VLAN на Cisco ACI фабриках.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
certificate_name
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию, это private_key имя без расширения.

Псевдонимы: cert_name
domain
Имя домена, который связывается с пулом VLAN.

Псевдонимы: domain_name, domain_profile
domain_type
    Варианты:
  • fc
  • l2dom
  • l3dom
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).
host
обязательно
IP-адрес или имя хоста APIC, разрешаемые хостом управления Ansible.

Псевдонимы: hostname
output_level
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь.
info добавляет информативный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
обязательно
Пароль для аутентификации.
Этот параметр исключает private_key. Если private_key также указан, будет использован он.
pool
Имя пула.

Псевдонимы: pool_name, vlan_pool
pool_allocation_mode
обязательно
    Варианты:
  • dynamic
  • static
Метод распределения VLAN для ресурсов.

Псевдонимы: allocation_mode, mode
port
Номер порта для подключения REST.
Значение по умолчанию зависит от параметра `use_ssl`.
private_key
обязательно
Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи.
Имя ключа (без расширения) используется как имя сертификата в ACI, если не указан certificate_name.
Этот параметр исключает password. Если password также указан, он будет проигнорирован.

Псевдонимы: cert_key
state
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для перечисления объекта или нескольких объектов.
timeout
int
Значение по умолчанию:
30
Таймаут уровня сокета в секундах.
use_proxy
bool
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах.
use_ssl
bool
    Варианты:
  • no
  • yes ←
Если no, вместо стандартного HTTPS соединения будет использовано HTTP соединение.
username Значение по умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
bool
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это следует установить в no только при работе с сайтами, контролируемыми лично, использующими самозаверяющие сертификаты.
vm_provider
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа виртуальных машин для доменных объектов VMM.
Поддержка Kubernetes добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat добавлена в ACI v3.1.

Примечания

Примечание

  • Параметры domain и vlan_pool должны существовать перед использованием этого модуля. Для этого можно использовать aci_domain и aci_vlan_pool.
  • Дополнительную информацию о внутреннем классе APIC infra:RsVlanNs можно найти в справочнике по модели управления информацией APIC https://developer.cisco.com/docs/apic-mim-ref/.
  • Более подробную информацию о управлении инфраструктурой ACI с помощью Ansible можно найти в руководстве Cisco ACI Руководство Cisco ACI.

Примеры

- name: Bind a VMM domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: vmw_dom
    domain_type: vmm
    pool: vmw_pool
    pool_allocation_mode: dynamic
    vm_provider: vmware
    state: present

- name: Remove a VMM domain to VLAN pool binding
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: vmw_dom
    domain_type: vmm
    pool: vmw_pool
    pool_allocation_mode: dynamic
    vm_provider: vmware
    state: absent

- name: Bind a physical domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: present

- name: Bind a physical domain to VLAN pool
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: absent

- name: Query an domain to VLAN pool binding
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: phys_pool
    pool_allocation_mode: static
    state: query

- name: Query all domain to VLAN pool bindings
  aci_domain_to_vlan_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain_type: phys
    state: query

Возвращаемые значения

Общие значения возвращаемых данных описаны здесь, ниже указаны поля, уникальные для этого модуля:

Ключ Результат Описание
current
список
успех
Текущая конфигурация из APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращённая APIC

Пример:
{'code': '122', 'text': 'неизвестный тип управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
HTTP-метод, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация из APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Собраная конфигурация из предоставленных пользователем параметров

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращённый API REST APIC (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный тип управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус от APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-URL, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

Этот модуль помечен как превью, что означает, что его интерфейс не гарантируется обратной совместимостью.

Техническое обслуживание

Этот модуль помечен как сообщество, что означает, что он поддерживается сообществом Ansible. Подробнее см. Техническое обслуживание и поддержка модулей.

Список других модулей, также поддерживаемых сообществом Ansible, см. здесь.

Автор

  • Dag Wieers (@dagwieers)

Подсказка

Если вы обнаружите какие-либо проблемы в этом документе, вы можете отредактировать его, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.6/modules/aci_domain_to_vlan_pool_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API