Spec-Zone.ru › Ansible 2.7

aci_domain_to_encap_pool – Привязка домена к пулам Encap (infra:RsVlanNs)

Новое в версии 2.5.

  • Обзор
  • Параметры
  • Примечания
  • См. также
  • Примеры
  • Возвращаемые значения
  • Статус

Обзор

  • Привязка домена к пулам Encap на устройствах Cisco ACI.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
certificate_name
-
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию это private_key базовое имя без расширения.

Псевдонимы: cert_name
domain
-
Имя домена, ассоциируемого с пулом Encap.

Псевдонимы: domain_name, domain_profile
domain_type
-
    Варианты:
  • fc
  • l2dom
  • l3dom
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).
host
- / обязательно
IP-адрес или имя хоста APIC, разрешимое контрольным хостом Ansible.

Псевдонимы: hostname
output_level
-
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь.
info добавляет информативный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
- / обязательно
Пароль для аутентификации.
Этот параметр исключает private_key. Если private_key также указан, будет использоваться он.
pool
-
Имя пула.

Псевдонимы: pool_name
pool_allocation_mode
-
    Варианты:
  • dynamic
  • static
Метод, используемый для выделения encaps к ресурсам.
Только vlan и vsan поддерживают режимы выделения.

Псевдонимы: allocation_mode, mode
pool_type
- / обязательно
    Варианты:
  • vlan
  • vsan
  • vxlan
Тип encaps pool.
port
-
Порт, используемый для REST-соединения.
Значение по умолчанию зависит от параметра `use_ssl`.
private_key
- / обязательно
Файл в формате PEM, содержащий ваш закрытый ключ, используемый для аутентификации на основе подписи.
Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name.
Этот параметр исключает password. Если password также указан, он будет проигнорирован.

Псевдонимы: cert_key
state
-
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для отображения объекта или нескольких объектов.
timeout
целое число
Значение по умолчанию:
30
Таймаут уровня сокета в секундах.
use_proxy
логическое
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах.
use_ssl
логическое
    Варианты:
  • no
  • yes ←
Если no, будет использоваться HTTP-соединение вместо стандартного HTTPS-соединения.
username
-
Значение по умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
логическое
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это следует установить в no только при работе с лично контролируемыми сайтами, использующими самоподписанные сертификаты.
vm_provider
-
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа виртуальных машин для доменных VMM.
Поддержка Kubernetes добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat добавлена в ACI v3.1.

Примечания

Примечание

  • Параметры domain и encap_pool должны существовать перед использованием этого модуля. Для этого можно использовать модули aci_domain и aci_encap_pool.
  • Дополнительную информацию о внутреннем классе APIC infra:RsVlanNs см. в справке по модели управления информацией APIC.

См. также

См. также

Руководство по Cisco ACI
Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Разработка модулей Cisco ACI
Подробное руководство по написанию собственных модулей Cisco ACI для вклада.

Примеры

- name: Add domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: present
  delegate_to: localhost

- name: Remove domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: absent
  delegate_to: localhost

- name: Query our domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query
  delegate_to: localhost
  register: query_result

- name: Query all domain to VLAN pool bindings
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain_type: phys
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query
  delegate_to: localhost
  register: query_result

Возвращаемые значения

Общие возвращаемые значения описаны в разделе здесь, следующие поля уникальны для этого модуля:

Ключ Возвращено Описание
current
список
успех
Текущая конфигурация из APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращенная APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
Метод HTTP, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация из APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Собраная конфигурация из параметров, предоставленных пользователем

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращенный REST API APIC (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус от APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-адрес, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

  • Данный модуль не гарантирует обратную совместимость. [превью]
  • Данный модуль поддерживается партнером Ansible. [сертифицировано]

Авторы

  • Dag Wieers (@dagwieers)

Подсказка

Если вы обнаружите какие-либо проблемы в этом руководстве, вы можете отредактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_domain_to_encap_pool_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API