Spec-Zone.ru › Ansible 2.7

aci_epg_to_domain – Привязка EPG к доменам (fv:RsDomAtt)

Новая в версии 2.4.

  • Описание
  • Параметры
  • Примечания
  • См. также
  • Примеры
  • Возвращаемые значения
  • Статус

Описание

  • Привязка EPG к физическим и виртуальным доменам на Cisco ACI фабриках.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
allow_useg
-
    Варианты:
  • encap
  • useg
Разрешает микросегментацию.
APIC по умолчанию использует encap при отсутствии указания при создании.
ap
-
Имя существующего профиля прикладной сети, который будет содержать EPG.

Псевдонимы: app_profile, app_profile_name
certificate_name
-
Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи.
По умолчанию используется private_key без расширения.

Псевдонимы: cert_name
deploy_immediacy
-
    Варианты:
  • immediate
  • lazy
Определяет, когда политика будет передана в Policy CAM оборудования.
APIC по умолчанию использует lazy при отсутствии указания при создании.
domain
-
Имя физического или виртуального домена, ассоциируемого с EPG.

Псевдонимы: domain_name, domain_profile
domain_type
-
    Варианты:
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).

Псевдонимы: type
encap
целое число
Капсулирование VLAN для EPG при привязке VMM домена со статическим encap_mode.
Выступает в качестве вторичного encap при использовании useg.
Допустимые значения находятся в диапазоне от 1 до 4096.
encap_mode
-
    Варианты:
  • auto
  • vlan
  • vxlan
Метод капсулирования, который необходимо использовать.
APIC по умолчанию использует auto при отсутствии указания при создании.
epg
-
Имя группы конечных точек.

Псевдонимы: epg_name, name
host
- / обязательно
IP-адрес или имя хоста APIC, разрешимые управляющим хостом Ansible.

Псевдонимы: hostname
netflow
логическое значение
    Варианты:
  • no
  • yes
Определяет, следует ли включить netflow.
APIC по умолчанию использует no при отсутствии указания при создании.
output_level
-
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь
info добавляет информативный вывод, включая previous, proposed и sent словари
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию
password
- / обязательно
Пароль для аутентификации.
Этот параметр взаимоисключающий с private_key. Если private_key также указан, будет использован он.
port
-
Номер порта для подключения REST.
Значение по умолчанию зависит от параметра `use_ssl`.
primary_encap
целое число
Определяет первичный идентификатор VLAN при использовании useg.
Допустимые значения находятся в диапазоне от 1 до 4096.
private_key
- / обязательно
Файл в формате PEM, содержащий ваш закрытый ключ для аутентификации на основе подписи.
Имя ключа (без расширения) используется в качестве имени сертификата в ACI, если не указан certificate_name.
Этот параметр взаимоисключающий с password. Если password также указан, он будет проигнорирован.

Псевдонимы: cert_key
resolution_immediacy
-
    Варианты:
  • immediate
  • lazy
  • pre-provision
Определяет, когда политики должны быть разрешены и доступны.
APIC по умолчанию использует lazy при отсутствии указания при создании.
state
-
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для отображения объекта или нескольких объектов.
tenant
-
Имя существующего арендатора.

Псевдонимы: tenant_name
timeout
целое число
По умолчанию:
30
Таймаут сокета в секундах.
use_proxy
логическое значение
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определён в переменной среды на целевых хостах.
use_ssl
логическое значение
    Варианты:
  • no
  • yes ←
Если no, будет использоваться соединение HTTP вместо стандартного HTTPS.
username
-
По умолчанию:
"admin"
Имя пользователя для аутентификации.

Псевдонимы: user
validate_certs
логическое значение
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверены.
Это следует устанавливать только в no при работе с сайтами, контролируемыми лично, использующими самозаверяющие сертификаты.
vm_provider
-
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа VM для VMM домена.
Поддержка Kubernetes была добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1.

Примечания

Примечание

  • Для использования этого модуля в вашем игровом наборе должны существовать tenant, ap, epg, и domain. Для этого можно использовать модули aci_tenant, aci_ap, aci_epg и aci_domain.
  • Домены VMM OpenStack не должны создаваться с помощью этого модуля. Домен OpenStack VMM создается напрямую плагином Cisco APIC Neutron во время установки и настройки. Этот модуль может использоваться для запроса состояния домена OpenStack VMM.
  • Дополнительную информацию о внутреннем классе APIC fv:RsDomAtt можно найти в справочнике по модели управления информацией APIC.

См. также

См. также

Руководство по Cisco ACI
Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Разработка модулей Cisco ACI
Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.

Примеры

- name: Add a new physical domain to EPG binding
  aci_epg_to_domain:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: anstest
    ap: anstest
    epg: anstest
    domain: anstest
    domain_type: phys
    state: present
  delegate_to: localhost

- name: Remove an existing physical domain to EPG binding
  aci_epg_to_domain:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: anstest
    ap: anstest
    epg: anstest
    domain: anstest
    domain_type: phys
    state: absent
  delegate_to: localhost

- name: Query a specific physical domain to EPG binding
  aci_epg_to_domain:
    host: apic
    username: admin
    password: SomeSecretPassword
    tenant: anstest
    ap: anstest
    epg: anstest
    domain: anstest
    domain_type: phys
    state: query
  delegate_to: localhost
  register: query_result

- name: Query all domain to EPG bindings
  aci_epg_to_domain:
    host: apic
    username: admin
    password: SomeSecretPassword
    state: query
  delegate_to: localhost
  register: query_result

Значения возврата

Общие значения возврата описаны здесь, а следующие — поля, уникальные для данного модуля:

Ключ Возвращаемое значение Описание
current
список
успех
Настройка, существующая в APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращенная APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
Метод HTTP, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация из APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Сборка конфигурации из параметров, предоставленных пользователем

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращенный APIC REST API (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
Ответ HTTP от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус от APIC

Пример:
200
url
строка
ошибка или отладка
Используемый HTTP-URL для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

  • Данный модуль не гарантирует обратной совместимости интерфейса. [превью]
  • Этот модуль поддерживается партнером Ansible. [сертифицировано]

Авторы

  • Jacob McGill (@jmcgill298)

Подсказка

Если вы обнаружите какие-либо проблемы в данной документации, вы можете редактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_epg_to_domain_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API