aci_static_binding_to_epg – Связывание статических путей с EPG (fv:RsPathAtt)
Новая версия 2.5.
Описание
- Связывание статических путей с EPG на Cisco ACI сетях.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| ap - | Имя существующего профиля сети приложения, который будет содержать EPG. Псевдонимы: app_profile, app_profile_name | |
| certificate_name - | Имя сертификата X.509, прикреплённого к пользователю APIC AAA, используемому для аутентификации на основе подписи. По умолчанию соответствует private_key имени файла без расширения.Псевдонимы: cert_name | |
| deploy_immediacy - |
| Непосредственность развертывания статического EPG на ПК, VPC или интерфейсе. APIC по умолчанию устанавливает lazy, если параметр не задан при создании. |
| description - добавлено в 2.7 | Описание статического пути для привязки EPG. Псевдонимы: descr | |
| encap_id целое число | Идентификатор инкапсуляции, ассоциирующий epg с путем интерфейса.Выступает в качестве вторичного encap_id при использовании микросегментации.Допустимые значения — любой допустимый идентификатор инкапсуляции для указанной инкапсуляции, в настоящее время диапазон от 1 до 4096. Псевдонимы: vlan, vlan_id | |
| epg - | Имя группы конечных точек. Псевдонимы: epg_name | |
| extpaths целое число | Часть целого значения extpaths в tDn.extpaths используется только если interface_type имеет значение fex.Обычно что-то вроде 1011. | |
| host - / обязательно | IP-адрес или имя хоста, разрешаемые хостом управления Ansible. Псевдонимы: hostname | |
| interface - | Часть строкового значения interface в tDn.Обычно группа политик, например, test-IntPolGrp или интерфейс следующего формата 1/7, в зависимости от interface_type. | |
| interface_mode - |
| Определяет, как метки уровня 2 будут считываться и добавляться к кадрам. Значения 802.1p и native идентичны.Значения access и untagged идентичны.Значения regular, tagged и trunk идентичны.APIC по умолчанию устанавливает trunk, если параметр не задан при создании.Псевдонимы: interface_mode_name, mode |
| interface_type - |
| Тип интерфейса для развертывания статического EPG. |
| leafs - | Идентификатор(ы) коммутатора, к которому относится interface.Когда interface_type равно switch_port, port_channel, или fex, тогда leafs — это строка с идентификатором листа.Когда interface_type равно vpc, тогда leafs — это список с идентификаторами обоих листов.Значение leafs обычно имеет вид '101' или '101-102', в зависимости от connection_type.Псевдонимы: leaves, nodes, paths, switches | |
| output_level - |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарь.info добавляет информативный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password - / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также предоставлен private_key, он будет использован вместо него. | |
| pod_id целое число | Номер подсети в tDn. pod_id обычно целое число меньше 10.Псевдонимы: pod, pod_number | |
| port - | Порт, используемый для подключения REST. Значение по умолчанию зависит от параметра `use_ssl`. | |
| primary_encap_id целое число | Определяет первичный идентификатор инкапсуляции, ассоциирующий epg с путем интерфейса при использовании микросегментации.Допустимые значения — любой допустимый идентификатор инкапсуляции для указанной инкапсуляции, в настоящее время диапазон от 1 до 4096.Псевдонимы: primary_vlan, primary_vlan_id | |
| private_key - / обязательно | Файл в формате PEM, содержащий ваш закрытый ключ, используемый для аутентификации на основе подписи. Имя ключа (без расширения) используется в ACI в качестве имени сертификата, если не задан certificate_name.Этот параметр взаимоисключающий с password. Если также предоставлен password, он будет проигнорирован.Псевдонимы: cert_key | |
| state - |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| tenant - | Имя существующего арендатора. Псевдонимы: tenant_name | |
| timeout целое число | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS соединения будет использовано HTTP соединение. |
| username - | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Этот параметр следует устанавливать в no только при использовании на сайтах под вашим контролем с самозаверяющими сертификатами. |
Примечания
Примечание
- Необходимо наличие
tenant,ap,epgперед использованием данного модуля в вашем плане. Модули aci_tenant, aci_ap, aci_epg могут быть использованы для этого. - Дополнительная информация об внутренних классах APIC fv:RsPathAtt из справочника по модели управления информацией APIC.
См. также
См. также
- Руководство Cisco ACI
- Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для участия.
Примеры
- name: Deploy Static Path binding for given EPG
aci_static_binding_to_epg:
host: apic
username: admin
password: SomeSecretPassword
tenant: accessport-code-cert
ap: accessport_code_app
epg: accessport_epg1
encap_id: 222
deploy_immediacy: lazy
interface_mode: untagged
interface_type: switch_port
pod_id: 1
leafs: 101
interface: '1/7'
state: present
delegate_to: localhost
- name: Remove Static Path binding for given EPG
aci_static_binding_to_epg:
host: apic
username: admin
password: SomeSecretPassword
tenant: accessport-code-cert
ap: accessport_code_app
epg: accessport_epg1
interface_type: switch_port
pod: 1
leafs: 101
interface: '1/7'
state: absent
delegate_to: localhost
- name: Get specific Static Path binding for given EPG
aci_static_binding_to_epg:
host: apic
username: admin
password: SomeSecretPassword
tenant: accessport-code-cert
ap: accessport_code_app
epg: accessport_epg1
interface_type: switch_port
pod: 1
leafs: 101
interface: '1/7'
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата описаны в этом разделе, следующие поля уникальны для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Существующая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращаемая из APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Используемая строка фильтра для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | Используемый HTTP-метод для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сформированная конфигурация из предоставленных пользователем параметров Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный вывод, возвращённый API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | Используемый HTTP-URL для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнёром Ansible. [сертифицированный]
Авторы
- Bruno Calogero (@brunocalogero)
Подсказка
Если вы заметили какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.7/modules/aci_static_binding_to_epg_module.html