aci_domain_to_vlan_pool – Привязка домена к пулам VLAN (infra:RsVlanNs)
Новая в версии 2.5.
Описание
- Привязка домена к пулам VLAN на Cisco ACI fabric.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если был предоставлен private_key имя файла, по умолчанию используется private_key без расширения.Если для private_key был предоставлен контент в формате PEM, по умолчанию используется значение username. Псевдонимы: cert_name | |
| domain строка | Имя домена, который будет связан с пулом VLAN. Псевдонимы: domain_name, domain_profile | |
| domain_type строка |
| Определяет, является ли домен физическим (phys) или виртуальным (vmm). |
| host строка / обязательно | IP-адрес или имя хоста, разрешаемого контрольным хостом Ansible. Псевдонимы: hostname | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, вкл. current словарь.info добавляет информативный вывод, вкл. previous, proposed и sent словари.debug добавляет отладочный вывод, вкл. filter_string, method, response, status и url информацию. |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также предоставлен private_key, он будет использован вместо него. | |
| pool строка | Имя пула. Псевдонимы: pool_name, vlan_pool | |
| pool_allocation_mode строка / обязательно |
| Метод, используемый для выделения VLAN ресурсам. Псевдонимы: allocation_mode, mode |
| port целое число | Номер порта, используемого для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемое для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если также предоставлен password, он будет проигнорирован.Псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Тайм-аут на уровне сокета в секундах. |
| use_proxy логическое значение |
| Если no, прокси не будет использован, даже если он определён в переменной среды целевых хостов. |
| use_ssl логическое значение |
| Если no, вместо стандартного HTTPS подключения будет использовано HTTP подключение. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs логическое значение |
| Если no, сертификаты SSL не будут проверены.Это должно быть установлено в no только при работе с лично контролируемыми сайтами, использующими самозаверенные сертификаты. |
| vm_provider строка |
| Платформа виртуальных машин для VMM доменов. Поддержка Kubernetes была добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1. |
Примечания
Примечание
- Параметры
domainиvlan_poolдолжны существовать перед использованием данного модуля. Для этого можно использовать модули aci_domain и aci_vlan_pool.
См. также
См. также
- aci_domain – Управление физическими, виртуальными, мостовыми, маршрутизируемыми или FC профилями доменов (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
- Официальная документация по модулю aci_domain.
- aci_vlan_pool – Управление пулами VLAN (fvns:VlanInstP)
- Официальная документация по модулю aci_vlan_pool.
- Справочник моделирования информации управления APIC
- Дополнительная информация об внутренней классы APIC infra:RsVlanNs.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Bind a VMM domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: vmw_dom
domain_type: vmm
pool: vmw_pool
pool_allocation_mode: dynamic
vm_provider: vmware
state: present
delegate_to: localhost
- name: Remove a VMM domain to VLAN pool binding
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: vmw_dom
domain_type: vmm
pool: vmw_pool
pool_allocation_mode: dynamic
vm_provider: vmware
state: absent
delegate_to: localhost
- name: Bind a physical domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: present
delegate_to: localhost
- name: Bind a physical domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: absent
delegate_to: localhost
- name: Query an domain to VLAN pool binding
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: query
delegate_to: localhost
register: query_result
- name: Query all domain to VLAN pool bindings
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain_type: phys
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая с APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка парсинга | Необработанный вывод, возвращённый APIC REST API (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус с APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-url, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Данный модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружили какие-либо проблемы в данном руководстве, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.8/modules/aci_domain_to_vlan_pool_module.html