Spec-Zone.ru › Ansible 2.9

aci_domain_to_encap_pool – Привязка домена к пулам Encap (infra:RsVlanNs)

Новая версия 2.5.

  • Обзор
  • Параметры
  • Примечания
  • См. также
  • Примеры
  • Возвращаемые значения
  • Статус

Обзор

  • Привязка домена к пулам Encap на Cisco ACI устройствах.

Параметры

Параметр Варианты/Значения по умолчанию Комментарии
certificate_name
строка
Имя сертификата X.509, прикреплённого к пользователю APIC AAA, используемому для аутентификации на основе подписи.
Если был предоставлено имя private_key, по умолчанию используется private_key базовое имя без расширения.
Если для private_key было предоставлено содержимое в формате PEM, по умолчанию используется username значение.

псевдонимы: cert_name
domain
строка
Имя домена, ассоциируемого с пулом Encap.

псевдонимы: domain_name, domain_profile
domain_type
строка
    Варианты:
  • fc
  • l2dom
  • l3dom
  • phys
  • vmm
Определяет, является ли домен физическим (phys) или виртуальным (vmm).
host
строка / обязательно
IP-адрес или имя хоста APIC, разрешаемое управляющим хостом Ansible.

псевдонимы: hostname
output_level
строка
    Варианты:
  • debug
  • info
  • normal ←
Влияет на вывод этого модуля ACI.
normal означает стандартный вывод, включая current словарь.
info добавляет информационный вывод, включая previous, proposed и sent словари.
debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию.
password
строка / обязательно
Пароль для аутентификации.
Этот параметр является взаимоисключающим с private_key. Если также предоставлен private_key, он будет использован вместо него.
pool
строка
Имя пула.

псевдонимы: pool_name
pool_allocation_mode
строка
    Варианты:
  • dynamic
  • static
Метод, используемый для выделения инкапсуляции ресурсам.
Только vlan и vsan поддерживают режимы выделения.

псевдонимы: allocation_mode, mode
pool_type
строка / обязательно
    Варианты:
  • vlan
  • vsan
  • vxlan
Тип инкапсуляции pool.
port
целое число
Номер порта, используемый для подключения REST.
Значение по умолчанию зависит от параметра use_ssl.
private_key
строка / обязательно
Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи.
Это значение также влияет на значение по умолчанию certificate_name.
Этот параметр взаимоисключающий с password. Если password также предоставлен, он будет проигнорирован.

псевдонимы: cert_key
state
строка
    Варианты:
  • absent
  • present ←
  • query
Используйте present или absent для добавления или удаления.
Используйте query для получения списка объекта или нескольких объектов.
timeout
целое число
По умолчанию:
30
Таймаут уровня сокета в секундах.
use_proxy
булево
    Варианты:
  • no
  • yes ←
Если no, прокси не будет использоваться, даже если он определён в переменной окружения на целевых хостах.
use_ssl
булево
    Варианты:
  • no
  • yes ←
Если no, будет использовано HTTP-соединение вместо стандартного HTTPS-соединения.
username
строка
По умолчанию:
"admin"
Имя пользователя для аутентификации.

псевдонимы: user
validate_certs
булево
    Варианты:
  • no
  • yes ←
Если no, сертификаты SSL не будут проверяться.
Это следует установить в no только при работе с сайтами под собственным контролем с использованием самозаверяющих сертификатов.
vm_provider
строка
    Варианты:
  • cloudfoundry
  • kubernetes
  • microsoft
  • openshift
  • openstack
  • redhat
  • vmware
Платформа виртуальных машин для доменных VMM.
Поддержка Kubernetes была добавлена в ACI v3.0.
Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1.

Примечания

Примечание

  • Параметры domain и encap_pool должны быть заданы перед использованием данного модуля. Для этого можно использовать модули aci_domain и aci_encap_pool.

См. также

См. также

aci_domain – Управление физическими, виртуальными, мостовыми, маршрутизированными или FC доменными профилями (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
Официальная документация модуля aci_domain.
aci_encap_pool – Управление пулами Encap (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
Официальная документация модуля aci_encap_pool.
Ссылка на модель управления информацией APIC
Дополнительная информация о внутренней модели класса APIC infra:RsVlanNs.
Руководство по Cisco ACI
Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
Разработка модулей Cisco ACI
Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.

Примеры

- name: Add domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: present
  delegate_to: localhost

- name: Remove domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    domain_type: phys
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: absent
  delegate_to: localhost

- name: Query our domain to VLAN pool binding
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain: phys_dom
    pool: test_pool
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query
  delegate_to: localhost
  register: query_result

- name: Query all domain to VLAN pool bindings
  aci_domain_to_encap_pool:
    host: apic
    username: admin
    password: SomeSecretPassword
    domain_type: phys
    pool_type: vlan
    pool_allocation_mode: dynamic
    state: query
  delegate_to: localhost
  register: query_result

Возвращаемые значения

Общие возвращаемые значения описаны здесь, следующие поля уникальны для данного модуля:

Ключ Возвращаемое значение Описание
current
список
успех
Текущая конфигурация из APIC после завершения модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
error
словарь
ошибка
Информация об ошибке, возвращаемая из APIC

Пример:
{'code': '122', 'text': 'неизвестный класс управляемого объекта foo'}
filter_string
строка
ошибка или отладка
Строка фильтра, используемая для запроса

Пример:
?rsp-prop-include=config-only
method
строка
ошибка или отладка
Метод HTTP, используемый для запроса к APIC

Пример:
POST
previous
список
информация
Исходная конфигурация из APIC до запуска модуля

Пример:
[{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}]
proposed
словарь
информация
Сформированная конфигурация из параметров пользователя

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}}
raw
строка
ошибка разбора
Необработанный вывод, возвращаемый APIC REST API (xml или json)

Пример:
<?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata>
response
строка
ошибка или отладка
HTTP-ответ от APIC

Пример:
OK (30 байт)
sent
список
информация
Фактическая/минимальная конфигурация, отправленная в APIC

Пример:
{'fvTenant': {'attributes': {'descr': 'Производственная среда'}}}
status
целое число
ошибка или отладка
HTTP-статус от APIC

Пример:
200
url
строка
ошибка или отладка
HTTP-адрес, используемый для запроса к APIC

Пример:
https://10.11.12.13/api/mo/uni/tn-production.json


Статус

  • Этот модуль не гарантирует обратной совместимости. [превью]
  • Этот модуль поддерживается партнером Ansible. [сертифицировано]

Авторы

  • Dag Wieers (@dagwieers)

Подсказка

Если вы заметите какие-либо проблемы в этом документе, вы можете отредактировать этот документ, чтобы улучшить его.

© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_domain_to_encap_pool_module.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API