aci_encap_pool – Управление пулами инкапсуляции (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
Новая версия 2.5.
Обзор
- Управление пулами VLAN, VXLAN и VSAN на Cisco ACI Fabric.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если был предоставлен private_key имя файла, по умолчанию используется private_key имя файла без расширения.Если для private_key был предоставлен контент в формате PEM, по умолчанию используется значение username. псевдонимы: cert_name | |
| description строка | Описание pool.псевдонимы: descr | |
| host строка / обязательно | IP-адрес или имя хоста APIC, разрешимый хостом управления Ansible. псевдонимы: hostname | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информативный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если также предоставлен private_key, будет использован он. | |
| pool строка | Имя пула. псевдонимы: name, pool_name | |
| pool_allocation_mode строка |
| Метод, используемый для распределения инкапсуляции ресурсам. Только vlan и vsan поддерживают режимы распределения. псевдонимы: allocation_mode, mode |
| pool_type строка / обязательно |
| Тип инкапсуляции pool.псевдонимы: type |
| port целое число | Порт, используемый для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name.Этот параметр взаимоисключающий с password. Если также предоставлен password, он будет проигнорирован.псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для получения списка объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут на уровне сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определен в переменной среды на целевых хостах. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS соединения будет использовано HTTP соединение. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует установить только на no когда используется на сайтах с собственными самоподписанными сертификатами. |
См. также
См. также
- aci_encap_pool_range – Управление диапазонами инкапсуляции, назначенными пулам (fvns:EncapBlk, fvns:VsanEncapBlk)
- Официальная документация модуля aci_encap_pool_range.
- aci_vlan_pool – Управление пулами VLAN (fvns:VlanInstP)
- Официальная документация модуля aci_vlan_pool.
- Справочник моделирования информации управления APIC
- Дополнительная информация о внутренних классах APIC fvns:VlanInstP, fvns:VxlanInstP и fvns:VsanInstP
- Руководство Cisco ACI
- Подробная информация о том, как управлять инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для внесения вклада.
Примеры
- name: Add a new vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
description: Production VLANs
state: present
delegate_to: localhost
- name: Remove a vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
state: absent
delegate_to: localhost
- name: Query a vlan pool
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
- name: Query all vlan pools
aci_encap_pool:
host: apic
username: admin
password: SomeSecretPassword
pool_type: vlan
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата описаны здесь, следующие — поля, уникальные для этого модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация из APIC после завершения модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC Пример: POST |
| previous список | информация | Исходная конфигурация из APIC до запуска модуля Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собранная конфигурация из параметров пользователя Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка парсинга | Необработанный результат, возвращённый API REST APIC (xml или json) Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная в APIC Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратной совместимости. [превью]
- Этот модуль поддерживается партнером Ansible. [сертифицировано]
Авторы
- Jacob McGill (@jmcgill298)
Подсказка
Если вы заметите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_encap_pool_module.html