aci_vlan_pool – Управление пулами VLAN (fvns:VlanInstP)
Новая в версии 2.5.
Описание
- Управление пулами VLAN на тканях Cisco ACI.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если был предоставлен private_key имя файла, по умолчанию используется private_key имя файла без расширения.Если для private_key был предоставлен контент в формате PEM, по умолчанию используется значение username. псевдонимы: cert_name | |
| description строка | Описание для pool. псевдонимы: descr | |
| host строка / обязательно | IP-адрес или имя хоста APIC, разрешаемое управляющим хостом Ansible. псевдонимы: hostname | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информационный вывод, включая previous, proposed и sent словари.debug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию. |
| password строка / обязательно | Пароль для аутентификации. Этот параметр взаимоисключающий с private_key. Если предоставлен private_key, он будет использован вместо него. | |
| pool строка | Имя пула. псевдонимы: name, pool_name | |
| pool_allocation_mode строка |
| Метод, используемый для выделения VLAN для ресурсов. псевдонимы: allocation_mode, mode |
| port целое число | Номер порта, используемый для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр взаимоисключающий с password. Если предоставлено password, оно будет проигнорировано.псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для перечисления объекта или нескольких объектов. |
| timeout целое число | Значение по умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое значение |
| Если no, не будет использоваться прокси-сервер, даже если он определён в переменной среды на целевых хостах. |
| use_ssl логическое значение |
| Если no, будет использоваться HTTP-соединение вместо стандартного HTTPS-соединения. |
| username строка | Значение по умолчанию: "admin" | Имя пользователя для аутентификации. псевдонимы: user |
| validate_certs логическое значение |
| Если no, сертификаты SSL не будут проверены.Это следует установить только в no при работе с сайтами под собственным контролем, использующими самозаверяющие сертификаты. |
См. также
См. также
- aci_encap_pool – Управление пулами encap (fvns:VlanInstP, fvns:VxlanInstP, fvns:VsanInstP)
- Официальная документация по модулю aci_encap_pool.
- aci_vlan_pool_encap_block – Управление блоками encap, назначенными пулам VLAN (fvns:EncapBlk)
- Официальная документация по модулю aci_vlan_pool_encap_block.
- Справочник по модели информации управления APIC
- Дополнительная информация о внутреннем классе APIC fvns:VlanInstP.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для участия.
Примеры
- name: Add a new VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
description: Production VLANs
state: present
delegate_to: localhost
- name: Remove a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: absent
delegate_to: localhost
- name: Query a VLAN pool
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
pool: production
pool_allocation_mode: dynamic
state: query
delegate_to: localhost
register: query_result
- name: Query all VLAN pools
aci_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
state: query
delegate_to: localhost
register: query_result
Значения возврата
Общие значения возврата описаны здесь, следующие — поля, уникальные для данного модуля:
| Ключ | Возвращаемое значение | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля. Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC. Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса. Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC. Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля. Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Собраная конфигурация из предоставленных пользователем параметров. Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка парсинга | Необработанный вывод, возвращённый API REST APIC (xml или json). Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ с APIC. Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC. Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-код состояния с APIC. Пример: 200 |
| url строка | ошибка или отладка | HTTP-адрес, используемый для запроса к APIC. Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнёром Ansible. [сертифицирован]
Авторы
- Jacob McGill (@jmcgill298)
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружите какие-либо проблемы в этой документации, вы можете изменить этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_vlan_pool_module.html