aci_domain_to_vlan_pool – Привязка домена к пулам VLAN (infra:RsVlanNs)
Новая версия с 2.5.
Описание
- Привязка домена к пулам VLAN на Cisco ACI фабриках.
Параметры
| Параметр | Варианты/Значения по умолчанию | Комментарии |
|---|---|---|
| certificate_name строка | Имя сертификата X.509, прикрепленного к пользователю APIC AAA, используемому для аутентификации на основе подписи. Если предоставлено имя файла private_key, по умолчанию используется имя файла private_key, без расширения.Если для private_key предоставлено содержимое в формате PEM, по умолчанию используется значение username. Псевдонимы: cert_name | |
| domain строка | Имя домена, связываемого с пулом VLAN. Псевдонимы: domain_name, domain_profile | |
| domain_type строка |
| Определяет, является ли домен физическим (phys) или виртуальным (vmm). |
| host строка / обязательно | IP-адрес или имя хоста, разрешаемое управляющим хостом Ansible. Псевдонимы: hostname | |
| output_level строка |
| Влияет на вывод этого модуля ACI. normal означает стандартный вывод, включая current словарьinfo добавляет информативный вывод, включая previous, proposed и sent словариdebug добавляет отладочный вывод, включая filter_string, method, response, status и url информацию |
| password строка / обязательно | Пароль для аутентификации. Этот параметр исключается из private_key. Если предоставлено также private_key, будет использоваться оно. | |
| pool строка | Имя пула. Псевдонимы: pool_name, vlan_pool | |
| pool_allocation_mode строка / обязательно |
| Способ распределения VLAN для ресурсов. Псевдонимы: allocation_mode, mode |
| port целое число | Номер порта для подключения REST. Значение по умолчанию зависит от параметра use_ssl. | |
| private_key строка / обязательно | Файл закрытого ключа в формате PEM или содержимое закрытого ключа, используемого для аутентификации на основе подписи. Это значение также влияет на значение по умолчанию certificate_name, которое используется.Этот параметр исключается из password. Если также предоставлено password, оно будет проигнорировано.Псевдонимы: cert_key | |
| state строка |
| Используйте present или absent для добавления или удаления.Используйте query для отображения объекта или нескольких объектов. |
| timeout целое число | По умолчанию: 30 | Таймаут уровня сокета в секундах. |
| use_proxy логическое |
| Если no, прокси не будет использоваться, даже если он определен в переменной окружения на целевых хостах. |
| use_ssl логическое |
| Если no, вместо стандартного HTTPS подключения будет использовано HTTP подключение. |
| username строка | По умолчанию: "admin" | Имя пользователя для аутентификации. Псевдонимы: user |
| validate_certs логическое |
| Если no, сертификаты SSL не будут проверены.Это следует устанавливать в no только при работе с контролируемыми сайтами, использующими самозаверяющие сертификаты. |
| vm_provider строка |
| Платформа виртуальных машин для доменных VMM. Поддержка Kubernetes была добавлена в ACI v3.0. Поддержка CloudFoundry, OpenShift и Red Hat была добавлена в ACI v3.1. |
Примечания
Примечание
- Параметры
domainиvlan_poolдолжны существовать перед использованием данного модуля. Для этого можно использовать модули aci_domain и aci_vlan_pool.
См. также
См. также
- aci_domain – Управление физическими, виртуальными, мостовыми, маршрутизированными или FC профилями домена (phys:DomP, vmm:DomP, l2ext:DomP, l3ext:DomP, fc:DomP)
- Официальная документация модуля aci_domain.
- aci_vlan_pool – Управление пулами VLAN (fvns:VlanInstP)
- Официальная документация модуля aci_vlan_pool.
- Ссылка на модель информации управления APIC
- Дополнительная информация о внутреннем классе APIC infra:RsVlanNs.
- Руководство по Cisco ACI
- Подробная информация о том, как управлять вашей инфраструктурой ACI с помощью Ansible.
- Разработка модулей Cisco ACI
- Подробное руководство по написанию собственных модулей Cisco ACI для вклада.
Примеры
- name: Bind a VMM domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: vmw_dom
domain_type: vmm
pool: vmw_pool
pool_allocation_mode: dynamic
vm_provider: vmware
state: present
delegate_to: localhost
- name: Remove a VMM domain to VLAN pool binding
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: vmw_dom
domain_type: vmm
pool: vmw_pool
pool_allocation_mode: dynamic
vm_provider: vmware
state: absent
delegate_to: localhost
- name: Bind a physical domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: present
delegate_to: localhost
- name: Bind a physical domain to VLAN pool
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: absent
delegate_to: localhost
- name: Query an domain to VLAN pool binding
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain: phys_dom
domain_type: phys
pool: phys_pool
pool_allocation_mode: static
state: query
delegate_to: localhost
register: query_result
- name: Query all domain to VLAN pool bindings
aci_domain_to_vlan_pool:
host: apic
username: admin
password: SomeSecretPassword
domain_type: phys
state: query
delegate_to: localhost
register: query_result
Возвращаемые значения
Общие возвращаемые значения описаны здесь, следующие поля уникальны для данного модуля:
| Ключ | Результат | Описание |
|---|---|---|
| current список | успех | Текущая конфигурация с APIC после завершения модуля. Пример: [{'fvTenant': {'attributes': {'descr': 'Производственная среда', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| error словарь | ошибка | Информация об ошибке, возвращённая APIC. Пример: {'code': '122', 'text': 'неизвестный класс управляемого объекта foo'} |
| filter_string строка | ошибка или отладка | Строка фильтра, используемая для запроса. Пример: ?rsp-prop-include=config-only |
| method строка | ошибка или отладка | HTTP-метод, используемый для запроса к APIC. Пример: POST |
| previous список | информация | Исходная конфигурация с APIC до запуска модуля. Пример: [{'fvTenant': {'attributes': {'descr': 'Производство', 'dn': 'uni/tn-production', 'name': 'production', 'nameAlias': '', 'ownerKey': '', 'ownerTag': ''}}}] |
| proposed словарь | информация | Сформированная конфигурация из параметров пользователя. Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда', 'name': 'production'}}} |
| raw строка | ошибка разбора | Необработанный результат, возвращённый REST API APIC (xml или json). Пример: <?xml version="1.0" encoding="UTF-8"?><imdata totalCount="1"><error code="122" text="неизвестный класс управляемого объекта foo"/></imdata> |
| response строка | ошибка или отладка | HTTP-ответ от APIC. Пример: OK (30 байт) |
| sent список | информация | Фактическая/минимальная конфигурация, отправленная на APIC. Пример: {'fvTenant': {'attributes': {'descr': 'Производственная среда'}}} |
| status целое число | ошибка или отладка | HTTP-статус от APIC. Пример: 200 |
| url строка | ошибка или отладка | HTTP-URL, используемый для запроса к APIC. Пример: https://10.11.12.13/api/mo/uni/tn-production.json |
Статус
- Этот модуль не гарантирует обратную совместимость. [превью]
- Этот модуль поддерживается партнёром Ansible. [сертифицировано]
Авторы
- Dag Wieers (@dagwieers)
Подсказка
Если вы обнаружите какие-либо проблемы в этой документации, вы можете отредактировать этот документ, чтобы улучшить его.
© 2012–2018 Michael DeHaan
© 2018–2019 Red Hat, Inc.
Licensed under the GNU General Public License version 3.
https://docs.ansible.com/ansible/2.9/modules/aci_domain_to_vlan_pool_module.html