Spec-Zone.ru › Kotlin 2

Default

kotlin-stdlib/kotlin.io.encoding/Base64/Default

Начиная с Kotlin: 2.2

object Default : Base64

Кодирование «base64», указанное в RFC 4648 section 4, Base 64 Encoding.

Для кодирования и декодирования используется «алфавит Base 64», определённый в таблице 1 RFC 4648 и состоящий из символов 'A'..'Z', 'a'..'z', '+' и '/'.

Для этого экземпляра задан параметр дополнения PaddingOption.PRESENT. При необходимости используйте функцию withPadding, чтобы создать новый экземпляр с другим параметром дополнения.

Операция кодирования не добавляет символ-разделитель строк. Операция декодирования вызывает исключение, если встречает символ, отсутствующий в алфавите base64.

Примеры

import kotlin.io.encoding.*
import kotlin.test.*

fun main() { 
   //sampleStart 
   val encoded = Base64.Default.encode("Hello? :> ".encodeToByteArray())
println(encoded) // SGVsbG8/IDo+IA== 
   //sampleEnd
}

Свойства

Mime

Начиная с Kotlin: 2.2

val Mime: Base64

Кодирование, указанное в RFC 2045 section 6.8, Base64 Content-Transfer-Encoding.

Pem

Начиная с Kotlin: 2.2

val Pem: Base64

Кодирование, указанное в RFC 1421 section 4.3.2.4, Base64 Content-Transfer-Encoding.

UrlSafe

Начиная с Kotlin: 2.2

val UrlSafe: Base64

Кодирование «base64url», указанное в RFC 4648 section 5, Base 64 Encoding with URL and Filename Safe Alphabet.

Функции

decode

Начиная с Kotlin: 2.2

fun decode(source: ByteArray, startIndex: Int = 0, endIndex: Int = source.size): ByteArray

Декодирует символы из указанного массива source или его поддиапазона. Возвращает ByteArray, содержащий полученные байты.

fun decode(source: CharSequence, startIndex: Int = 0, endIndex: Int = source.length): ByteArray

Декодирует символы из указанной символьной последовательности source или её подстроки. Возвращает ByteArray, содержащий полученные байты.

decodeIntoByteArray

Начиная с Kotlin: 2.2

fun decodeIntoByteArray(source: ByteArray, destination: ByteArray, destinationOffset: Int = 0, startIndex: Int = 0, endIndex: Int = source.size): Int

Декодирует символы из указанного массива source или его поддиапазона и записывает полученные байты в массив destination. Возвращает количество записанных байтов.

fun decodeIntoByteArray(source: CharSequence, destination: ByteArray, destinationOffset: Int = 0, startIndex: Int = 0, endIndex: Int = source.length): Int

Декодирует символы из указанной символьной последовательности source или её подстроки и записывает полученные байты в массив destination. Возвращает количество записанных байтов.

encode

Начиная с Kotlin: 2.2

fun encode(source: ByteArray, startIndex: Int = 0, endIndex: Int = source.size): String

Кодирует байты из указанного массива source или его поддиапазона. Возвращает строку с полученными символами.

encodeIntoByteArray

Начиная с Kotlin: 2.2

fun encodeIntoByteArray(source: ByteArray, destination: ByteArray, destinationOffset: Int = 0, startIndex: Int = 0, endIndex: Int = source.size): Int

Кодирует байты из указанного массива source или его поддиапазона и записывает полученные символы в массив destination. Возвращает количество записанных символов.

encodeToAppendable

Начиная с Kotlin: 2.2

@IgnorableReturnValue
fun <A : Appendable> encodeToAppendable(source: ByteArray, destination: A, startIndex: Int = 0, endIndex: Int = source.size): A

Кодирует байты из указанного массива source или его поддиапазона и добавляет полученные символы в объект destination, поддерживающий добавление. Возвращает объект destination.

encodeToByteArray

Начиная с Kotlin: 2.2

fun encodeToByteArray(source: ByteArray, startIndex: Int = 0, endIndex: Int = source.size): ByteArray

Кодирует байты из указанного массива source или его поддиапазона. Возвращает ByteArray, содержащий полученные символы.

withPadding

Начиная с Kotlin: 2.2

fun withPadding(option: Base64.PaddingOption): Base64

Возвращает новый экземпляр Base64, эквивалентный этому экземпляру, но настроенный с указанным параметром дополнения.

© 2010–2026 JetBrains s.r.o. and Kotlin Programming Language contributors
Licensed under the Apache License, Version 2.0.
https://kotlinlang.org/api/core/kotlin-stdlib/kotlin.io.encoding/-base64/-default/

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API