Spec-Zone.ru › MySQL 9.2

15.1.6 Заявление ALTER LOGFILE GROUP

ALTER LOGFILE GROUP logfile_group
    ADD UNDOFILE 'file_name'
    [INITIAL_SIZE [=] size]
    [WAIT]
    ENGINE [=] engine_name

Это утверждение добавляет файл UNDO с именем 'file_name' в существующую группу файлов журнала logfile_group. Утверждение ALTER LOGFILE GROUP имеет только один и единственный ADD UNDOFILE операнд. Сейчас не поддерживается DROP UNDOFILE операнд.

Примечание

Все объекты данных на диске NDB Cluster используют один и тот же пространственный охват. Это означает, что каждый объект данных на диске должен иметь уникальное имя (а не только каждый объект данных определенного типа). Например, вы не можете иметь табличное пространство и файл журнала отката с одинаковым именем, или файл журнала отката и файл данных с одинаковым именем.

Необязательный параметр INITIAL_SIZE устанавливает начальный размер файла UNDO в байтах; если не указано, начальный размер по умолчанию составляет 134217728 (128 МБ). Вы можете дополнительно указать после size однобуквенное сокращение для порядка величины, аналогичное используемым в my.cnf. Обычно это одна из букв M (мегабайты) или G (гигабайты). (Ошибка #13116514, Ошибка #16104705, Ошибка #62858)

В 32-битных системах максимальное поддерживаемое значение для INITIAL_SIZE составляет 4294967296 (4 ГБ). (Ошибка #29186)

Минимально допустимое значение для INITIAL_SIZE составляет 1048576 (1 МБ). (Ошибка #29574)

Примечание

WAIT анализируется, но в противном случае игнорируется. Это ключевое слово в настоящее время не оказывает никакого влияния и предназначено для будущего расширения.

Обязательный операнд ENGINE определяет движок хранения, который используется этой группой файлов журнала, где engine_name — имя движка хранения. В настоящее время единственные допустимые значения для engine_name — “NDBCLUSTER” и “NDB”. Эти два значения эквивалентны.

Вот пример, предполагающий, что группа файлов журнала lg_3 уже была создана с помощью CREATE LOGFILE GROUP (см. Раздел 15.1.17, «Заявление CREATE LOGFILE GROUP»):

ALTER LOGFILE GROUP lg_3
    ADD UNDOFILE 'undo_10.dat'
    INITIAL_SIZE=32M
    ENGINE=NDBCLUSTER;

При использовании ALTER LOGFILE GROUP с ENGINE = NDBCLUSTER (или ENGINE = NDB) на каждом узле данных NDB Cluster создается файл журнала отката. Вы можете проверить, были ли созданы файлы отката, и получить информацию о них, запросив таблицу Справочник информации FILES. Например:

mysql> SELECT FILE_NAME, LOGFILE_GROUP_NUMBER, EXTRA
    -> FROM INFORMATION_SCHEMA.FILES
    -> WHERE LOGFILE_GROUP_NAME = 'lg_3';
+-------------+----------------------+----------------+
| FILE_NAME   | LOGFILE_GROUP_NUMBER | EXTRA          |
+-------------+----------------------+----------------+
| newdata.dat |                    0 | CLUSTER_NODE=3 |
| newdata.dat |                    0 | CLUSTER_NODE=4 |
| undo_10.dat |                   11 | CLUSTER_NODE=3 |
| undo_10.dat |                   11 | CLUSTER_NODE=4 |
+-------------+----------------------+----------------+
4 rows in set (0.01 sec)

(См. Раздел 28.3.15, «Таблица INFORMATION_SCHEMA FILES».)

Память, используемая для UNDO_BUFFER_SIZE, берется из глобального пула, размер которого определяется значением параметра конфигурации узла данных SharedGlobalMemory. Это включает в себя любое значение по умолчанию, предполагаемое для этого параметра настройкой параметра конфигурации узла данных InitialLogFileGroup.

ALTER LOGFILE GROUP полезна только с хранилищем данных на диске для NDB Cluster. Дополнительную информацию см. в Разделе 25.6.11, «Таблицы NDB Cluster Disk Data».

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-9.2-en/alter-logfile-group.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API