http — модули HTTP
Исходный код: Lib/http/__init__.py
http — это пакет, объединяющий несколько модулей для работы с протоколом передачи гипертекста:
-
http.client— низкоуровневый клиент протокола HTTP; для открытия URL на более высоком уровне используйтеurllib.request -
http.serverсодержит базовые классы HTTP-сервера на основеsocketserver -
http.cookiesсодержит утилиты для реализации управления состоянием с помощью файлов cookie -
http.cookiejarобеспечивает сохранение файлов cookie
Модуль http также определяет следующие перечисления, помогающие работать с кодом, связанным с HTTP:
-
class http.HTTPStatus -
Добавлено в версии 3.5.
Подкласс
enum.IntEnum, определяющий набор кодов состояния HTTP, фраз с причинами и подробных описаний на английском языке.Использование:
>>> from http import HTTPStatus >>> HTTPStatus.OK HTTPStatus.OK >>> HTTPStatus.OK == 200 True >>> HTTPStatus.OK.value 200 >>> HTTPStatus.OK.phrase 'OK' >>> HTTPStatus.OK.description 'Request fulfilled, document follows' >>> list(HTTPStatus) [HTTPStatus.CONTINUE, HTTPStatus.SWITCHING_PROTOCOLS, ...]
Коды состояния HTTP
Поддерживаемые коды состояния, зарегистрированные в IANA и доступные в http.HTTPStatus:
Код | Имя перечисления | Подробности |
|---|---|---|
|
| Семантика HTTP RFC 9110, раздел 15.2.1 |
|
| Семантика HTTP RFC 9110, раздел 15.2.2 |
|
| WebDAV RFC 2518, раздел 10.1 |
|
| Код состояния HTTP для обозначения подсказок RFC 8297 |
|
| Семантика HTTP RFC 9110, раздел 15.3.1 |
|
| Семантика HTTP RFC 9110, раздел 15.3.2 |
|
| Семантика HTTP RFC 9110, раздел 15.3.3 |
|
| Семантика HTTP RFC 9110, раздел 15.3.4 |
|
| Семантика HTTP RFC 9110, раздел 15.3.5 |
|
| Семантика HTTP RFC 9110, раздел 15.3.6 |
|
| Семантика HTTP RFC 9110, раздел 15.3.7 |
|
| WebDAV RFC 4918, раздел 11.1 |
|
| Расширения привязки WebDAV RFC 5842, раздел 7.1 (экспериментальный) |
|
| Дельта-кодирование в HTTP RFC 3229, раздел 10.4.1 |
|
| Семантика HTTP RFC 9110, раздел 15.4.1 |
|
| Семантика HTTP RFC 9110, раздел 15.4.2 |
|
| Семантика HTTP RFC 9110, раздел 15.4.3 |
|
| Семантика HTTP RFC 9110, раздел 15.4.4 |
|
| Семантика HTTP RFC 9110, раздел 15.4.5 |
|
| Семантика HTTP RFC 9110, раздел 15.4.6 |
|
| Семантика HTTP RFC 9110, раздел 15.4.8 |
|
| Семантика HTTP RFC 9110, раздел 15.4.9 |
|
| Семантика HTTP RFC 9110, раздел 15.5.1 |
|
| Семантика HTTP RFC 9110, раздел 15.5.2 |
|
| Семантика HTTP RFC 9110, раздел 15.5.3 |
|
| Семантика HTTP RFC 9110, раздел 15.5.4 |
|
| Семантика HTTP RFC 9110, раздел 15.5.5 |
|
| Семантика HTTP RFC 9110, раздел 15.5.6 |
|
| Семантика HTTP RFC 9110, раздел 15.5.7 |
|
| Семантика HTTP RFC 9110, раздел 15.5.8 |
|
| Семантика HTTP RFC 9110, раздел 15.5.9 |
|
| Семантика HTTP RFC 9110, раздел 15.5.10 |
|
| Семантика HTTP RFC 9110, раздел 15.5.11 |
|
| Семантика HTTP RFC 9110, раздел 15.5.12 |
|
| Семантика HTTP RFC 9110, раздел 15.5.13 |
|
| Семантика HTTP RFC 9110, раздел 15.5.14 |
|
| Семантика HTTP RFC 9110, раздел 15.5.15 |
|
| Семантика HTTP RFC 9110, раздел 15.5.16 |
|
| Семантика HTTP RFC 9110, раздел 15.5.17 |
|
| Семантика HTTP RFC 9110, раздел 15.5.18 |
|
| HTCPCP/1.0 RFC 2324, раздел 2.3.2 |
|
| Семантика HTTP RFC 9110, раздел 15.5.20 |
|
| Семантика HTTP RFC 9110, раздел 15.5.21 |
|
| WebDAV RFC 4918, раздел 11.3 |
|
| WebDAV RFC 4918, раздел 11.4 |
|
| Использование ранних данных в HTTP RFC 8470 |
|
| Семантика HTTP RFC 9110, раздел 15.5.22 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Дополнительные коды состояния HTTP RFC 6585 |
|
| Код состояния HTTP для сообщения о юридических препятствиях RFC 7725 |
|
| Семантика HTTP RFC 9110, раздел 15.6.1 |
|
| Семантика HTTP RFC 9110, раздел 15.6.2 |
|
| Семантика HTTP RFC 9110, раздел 15.6.3 |
|
| Семантика HTTP RFC 9110, раздел 15.6.4 |
|
| Семантика HTTP RFC 9110, раздел 15.6.5 |
|
| Семантика HTTP RFC 9110, раздел 15.6.6 |
|
| Прозрачное согласование содержимого в HTTP RFC 2295, раздел 8.1 (экспериментальный) |
|
| WebDAV RFC 4918, раздел 11.5 |
|
| Расширения привязки WebDAV RFC 5842, раздел 7.2 (экспериментальный) |
|
| Инфраструктура расширений HTTP RFC 2774, раздел 7 (экспериментальный) |
|
| Дополнительные коды состояния HTTP RFC 6585, раздел 6 |
Для сохранения обратной совместимости значения перечисления также представлены в модуле http.client в виде констант. Имя перечисления совпадает с именем константы (то есть http.HTTPStatus.OK также доступно как http.client.OK).
Изменено в версии 3.7: Добавлен код состояния 421 MISDIRECTED_REQUEST.
Добавлено в версии 3.8: Добавлен код состояния 451 UNAVAILABLE_FOR_LEGAL_REASONS.
Добавлено в версии 3.9: Добавлены коды состояния 103 EARLY_HINTS, 418 IM_A_TEAPOT и 425 TOO_EARLY.
Изменено в версии 3.13: Для констант кодов состояния реализованы имена в соответствии с RFC 9110. Старые имена констант сохранены для обратной совместимости: 413 REQUEST_ENTITY_TOO_LARGE, 414 REQUEST_URI_TOO_LONG, 416 REQUESTED_RANGE_NOT_SATISFIABLE и 422 UNPROCESSABLE_ENTITY.
Категория кода состояния HTTP
Добавлено в версии 3.12.
Значения перечисления имеют несколько свойств, указывающих категорию кода состояния HTTP:
Свойство | Указывает, что | Подробности |
|---|---|---|
|
| Семантика HTTP RFC 9110, раздел 15 |
|
| Семантика HTTP RFC 9110, раздел 15 |
|
| Семантика HTTP RFC 9110, раздел 15 |
|
| Семантика HTTP RFC 9110, раздел 15 |
|
| Семантика HTTP RFC 9110, раздел 15 |
Использование:
>>> from http import HTTPStatus >>> HTTPStatus.OK.is_success True >>> HTTPStatus.OK.is_client_error False
-
class http.HTTPMethod -
Добавлено в версии 3.11.
Подкласс
enum.StrEnum, определяющий набор методов HTTP и описаний на английском языке.Использование:
>>> from http import HTTPMethod >>> >>> HTTPMethod.GET <HTTPMethod.GET> >>> HTTPMethod.GET == 'GET' True >>> HTTPMethod.GET.value 'GET' >>> HTTPMethod.GET.description 'Retrieve the target.' >>> list(HTTPMethod) [<HTTPMethod.CONNECT>, <HTTPMethod.DELETE>, <HTTPMethod.GET>, <HTTPMethod.HEAD>, <HTTPMethod.OPTIONS>, <HTTPMethod.PATCH>, <HTTPMethod.POST>, <HTTPMethod.PUT>, <HTTPMethod.TRACE>]
Методы HTTP
Поддерживаемые методы, зарегистрированные в IANA и доступные в http.HTTPMethod:
Метод | Имя перечисления | Подробности |
|---|---|---|
|
| Семантика HTTP RFC 9110, раздел 9.3.1 |
|
| Семантика HTTP RFC 9110, раздел 9.3.2 |
|
| Семантика HTTP RFC 9110, раздел 9.3.3 |
|
| Семантика HTTP RFC 9110, раздел 9.3.4 |
|
| Семантика HTTP RFC 9110, раздел 9.3.5 |
|
| Семантика HTTP RFC 9110, раздел 9.3.6 |
|
| Семантика HTTP RFC 9110, раздел 9.3.7 |
|
| Семантика HTTP RFC 9110, раздел 9.3.8 |
|
| HTTP/1.1 RFC 5789 |
© 2001 Python Software Foundation
Licensed under the PSF License.
https://docs.python.org/3.14/library/http.html