класс ActionDispatch::Request
Константы
- ENV_METHODS
- HTTP_METHODS
- HTTP_METHOD_LOOKUP
- LOCALHOST
- RFC2518
- RFC2616
-
Список методов HTTP-запросов из следующих RFC: Протокол передачи гипертекста – HTTP/1.1 (www.ietf.org/rfc/rfc2616.txt) Расширения HTTP для распределённого редактирования – WEBDAV (www.ietf.org/rfc/rfc2518.txt) Расширения версии для WebDAV (www.ietf.org/rfc/rfc3253.txt) Протокол упорядоченных коллекций (WebDAV) (www.ietf.org/rfc/rfc3648.txt) Протокол доступа к управлению распределённым авторством и версиями (WebDAV) (www.ietf.org/rfc/rfc3744.txt) ПОИСК WebDAV распределённого авторства и управления версиями (www.ietf.org/rfc/rfc5323.txt) Расширения календаря для WebDAV (www.ietf.org/rfc/rfc4791.txt) PATCH
Methodдля HTTP (www.ietf.org/rfc/rfc5789.txt) - RFC3253
- RFC3648
- RFC3744
- RFC4791
- RFC5323
- RFC5789
Публичные методы класса
# File actionpack/lib/action_dispatch/http/request.rb, line 56
def self.empty
new({})
end # File actionpack/lib/action_dispatch/http/request.rb, line 60 def initialize(env) super @method = nil @request_method = nil @remote_ip = nil @original_fullpath = nil @fullpath = nil @ip = nil end
ActionDispatch::Http::URL::new Общедоступные методы экземпляров
# File actionpack/lib/action_dispatch/http/request.rb, line 372
def GET
fetch_header("action_dispatch.request.query_parameters") do |k|
rack_query_params = super || {}
controller = path_parameters[:controller]
action = path_parameters[:action]
rack_query_params = Request::Utils.set_binary_encoding(self, rack_query_params, controller, action)
# Check for non UTF-8 parameter values, which would cause errors later
Request::Utils.check_param_encoding(rack_query_params)
set_header k, Request::Utils.normalize_encode_params(rack_query_params)
end
rescue Rack::Utils::ParameterTypeError, Rack::Utils::InvalidParameterError => e
raise ActionController::BadRequest.new("Invalid query parameters: #{e.message}")
end Переопределяет метод GET Rack для поддержки безразличного доступа.
# File actionpack/lib/action_dispatch/http/request.rb, line 388
def POST
fetch_header("action_dispatch.request.request_parameters") do
pr = parse_formatted_parameters(params_parsers) do |params|
super || {}
end
pr = Request::Utils.set_binary_encoding(self, pr, path_parameters[:controller], path_parameters[:action])
Request::Utils.check_param_encoding(pr)
self.request_parameters = Request::Utils.normalize_encode_params(pr)
end
rescue Rack::Utils::ParameterTypeError, Rack::Utils::InvalidParameterError => e
raise ActionController::BadRequest.new("Invalid request parameters: #{e.message}")
end Переопределяет метод POST Rack для поддержки безразличного доступа.
# File actionpack/lib/action_dispatch/http/request.rb, line 404
def authorization
get_header("HTTP_AUTHORIZATION") ||
get_header("X-HTTP_AUTHORIZATION") ||
get_header("X_HTTP_AUTHORIZATION") ||
get_header("REDIRECT_X_HTTP_AUTHORIZATION")
end Возвращает заголовок авторизации независимо от того, был ли он указан напрямую или через один из альтернативных прокси-серверов.
# File actionpack/lib/action_dispatch/http/request.rb, line 334
def body
if raw_post = get_header("RAW_POST_DATA")
raw_post = (+raw_post).force_encoding(Encoding::BINARY)
StringIO.new(raw_post)
else
body_stream
end
end Тело запроса — это потоковое входное значение IO. Если переменная среды RAW_POST_DATA уже установлена, оберните её в StringIO.
# File actionpack/lib/action_dispatch/http/request.rb, line 425 def commit_flash end
# File actionpack/lib/action_dispatch/http/request.rb, line 270 def content_length super.to_i end
Возвращает длину тела запроса как целое число.
# File actionpack/lib/action_dispatch/http/request.rb, line 79 def controller_class params = path_parameters params[:action] ||= "index" controller_class_for(params[:controller]) end
# File actionpack/lib/action_dispatch/http/request.rb, line 85
def controller_class_for(name)
if name
controller_param = name.underscore
const_name = controller_param.camelize << "Controller"
begin
const_name.constantize
rescue NameError => error
if error.missing_name == const_name || const_name.start_with?("#{error.missing_name}::")
raise MissingController.new(error.message, error.name)
else
raise
end
end
else
PASS_NOT_FOUND
end
end # File actionpack/lib/action_dispatch/http/request.rb, line 351 def form_data? FORM_DATA_MEDIA_TYPES.include?(media_type) end
Определяет, содержит ли тело запроса данные формы, проверяя заголовок Content-Type запроса на соответствие одному из типов медиа: “application/x-www-form-urlencoded” или “multipart/form-data”. Список типов медиа данных формы можно изменить через массив FORM_DATA_MEDIA_TYPES.
Тело запроса не предполагается содержащим данные формы, когда заголовок Content-Type не указан, а request_method равен POST.
# File actionpack/lib/action_dispatch/http/request.rb, line 249 def fullpath @fullpath ||= super end
Возвращает полную String путь, включая параметры последнего запрошенного URL.
# get "/articles" request.fullpath # => "/articles" # get "/articles?page=2" request.fullpath # => "/articles?page=2"
# File actionpack/lib/action_dispatch/http/request.rb, line 210 def headers @headers ||= Http::Headers.new(self) end
Обеспечивает доступ к HTTP-заголовкам запроса, например:
request.headers["Content-Type"] # => "text/plain"
# File actionpack/lib/action_dispatch/http/request.rb, line 179 def http_auth_salt get_header "action_dispatch.http_auth_salt" end
# File actionpack/lib/action_dispatch/http/request.rb, line 283 def ip @ip ||= super end
Возвращает IP-адрес клиента как String.
# File actionpack/lib/action_dispatch/http/request.rb, line 106 def key?(key) has_header? key end
Возвращает true, если запрос имеет заголовок, соответствующий заданному параметру key.
request.key? :ip_spoofing_check # => true
# File actionpack/lib/action_dispatch/http/request.rb, line 412 def local? LOCALHOST.match?(remote_addr) && LOCALHOST.match?(remote_ip) end
True, если запрос пришёл с localhost, 127.0.0.1 или ::1.
# File actionpack/lib/action_dispatch/http/request.rb, line 421
def logger
get_header("action_dispatch.logger")
end # File actionpack/lib/action_dispatch/http/request.rb, line 265 def media_type content_mime_type&.to_s end
Тип MIME запроса String.
# get "/articles" request.media_type # => "application/x-www-form-urlencoded"
# File actionpack/lib/action_dispatch/http/request.rb, line 198
def method
@method ||= check_method(get_header("rack.methodoverride.original_method") || get_header("REQUEST_METHOD"))
end Возвращает исходное значение REQUEST_METHOD среды, даже если оно было переопределено middleware. Подробнее см. request_method.
# File actionpack/lib/action_dispatch/http/request.rb, line 203 def method_symbol HTTP_METHOD_LOOKUP[method] end
Возвращает символическую форму method.
# File actionpack/lib/action_dispatch/http/request.rb, line 238
def original_fullpath
@original_fullpath ||= (get_header("ORIGINAL_FULLPATH") || fullpath)
end Возвращает String с последним запрошенным путём, включая параметры.
# get '/foo' request.original_fullpath # => '/foo' # get '/foo?bar' request.original_fullpath # => '/foo?bar'
# File actionpack/lib/action_dispatch/http/request.rb, line 257 def original_url base_url + original_fullpath end
Возвращает исходный URL запроса в виде String.
# get "/articles?page=2" request.original_url # => "http://www.example.com/articles?page=2"
# File actionpack/lib/action_dispatch/http/request.rb, line 323
def raw_post
unless has_header? "RAW_POST_DATA"
raw_post_body = body
set_header("RAW_POST_DATA", raw_post_body.read(content_length))
raw_post_body.rewind if raw_post_body.respond_to?(:rewind)
end
get_header "RAW_POST_DATA"
end Прочитать тело запроса. Это полезно для веб-сервисов, которым необходимо работать непосредственно с сырыми запросами.
# File actionpack/lib/action_dispatch/http/request.rb, line 289
def remote_ip
@remote_ip ||= (get_header("action_dispatch.remote_ip") || ip).to_s
end Возвращает IP-адрес клиента как String, обычно устанавливаемый middleware RemoteIp.
# File actionpack/lib/action_dispatch/http/request.rb, line 293 def remote_ip=(remote_ip) @remote_ip = nil set_header "action_dispatch.remote_ip", remote_ip end
# File actionpack/lib/action_dispatch/http/request.rb, line 306 def request_id get_header ACTION_DISPATCH_REQUEST_ID end
Возвращает уникальный идентификатор запроса, который основан на заголовке X-Request-Id, который может быть сгенерирован брандмауэром, балансировщиком нагрузки или веб-сервером, или с помощью middleware RequestId (который устанавливает переменную среды action_dispatch.request_id).
Этот уникальный идентификатор полезен для отслеживания запроса от начала до конца в рамках ведения журналов или отладки. Это зависит от переменной Rack, установленной middleware ActionDispatch::RequestId.
# File actionpack/lib/action_dispatch/http/request.rb, line 145 def request_method @request_method ||= check_method(super) end
Возвращает HTTP-метод, который должно увидеть приложение. В случае, если метод был переопределён middleware (например, если запрос HEAD был преобразован в GET, или если параметр _method был использован для определения метода, который должно использовать приложение), этот метод возвращает переопределённое значение, а не исходное.
# File actionpack/lib/action_dispatch/http/request.rb, line 191 def request_method_symbol HTTP_METHOD_LOOKUP[request_method] end
Возвращает символ формы request_method.
# File actionpack/lib/action_dispatch/http/request.rb, line 416
def request_parameters=(params)
raise if params.nil?
set_header("action_dispatch.request.request_parameters", params)
end # File actionpack/lib/action_dispatch/http/request.rb, line 359 def reset_session session.destroy end
# File actionpack/lib/action_dispatch/http/request.rb, line 225 def send_early_hints(links) return unless env["rack.early_hints"] env["rack.early_hints"].call(links) end
Early Hints — это HTTP/2 статус-код, который указывает подсказки для подготовки клиента к обработке конечного ответа.
Если env содержит rack.early_hints , сервер принимает HTTP2 push для заголовков Link.
Метод send_early_hints принимает хеш ссылок следующим образом:
send_early_hints("Link" => "</style.css>; rel=preload; as=style\n</script.js>; rel=preload")
Если вы используете javascript_include_tag или stylesheet_link_tag, заголовки Early Hints включаются по умолчанию, если они поддерживаются.
# File actionpack/lib/action_dispatch/http/request.rb, line 317
def server_software
(get_header("SERVER_SOFTWARE") && /^([a-zA-Z]+)/ =~ get_header("SERVER_SOFTWARE")) ? $1.downcase : nil
end Возвращает имя HTTP-сервера в нижнем регистре.
# File actionpack/lib/action_dispatch/http/request.rb, line 367 def session_options=(options) Session::Options.set self, options end
# File actionpack/lib/action_dispatch/http/request.rb, line 277
def xml_http_request?
/XMLHttpRequest/i.match?(get_header("HTTP_X_REQUESTED_WITH"))
end Возвращает true, если заголовок “X-Requested-With” содержит “XMLHttpRequest” (регистронезависимо), что может потребоваться добавить вручную, в зависимости от выбора JavaScript библиотек и фреймворков.
© 2004–2021 David Heinemeier Hansson
Licensed under the MIT License.