Spec-Zone.ru › Ruby on Rails 8.1

класс ActionDispatch::Request

Родительский класс:
Object
Подключённые модули:
ActionDispatch::Http::Cache::Request, ActionDispatch::Http::MimeNegotiation, ActionDispatch::Http::Parameters, ActionDispatch::Http::FilterParameters, ActionDispatch::Http::URL, ActionDispatch::ContentSecurityPolicy::Request

Константы

ENV_METHODS
HTTP_METHODS
HTTP_METHOD_LOOKUP
LOCALHOST
RFC2518

Методы HTTP из RFC 2518: расширения HTTP для распределённого создания документов — WEBDAV

RFC2616

Методы HTTP из RFC 2616: протокол передачи гипертекста — HTTP/1.1

RFC3253

Методы HTTP из RFC 3253: расширения управления версиями для WebDAV

RFC3648

Методы HTTP из RFC 3648: протокол упорядоченных коллекций WebDAV

RFC3744

Методы HTTP из RFC 3744: протокол управления доступом WebDAV

RFC4791

Методы HTTP из RFC 4791: расширения календарей для WebDAV

RFC5323

Методы HTTP из RFC 5323: поиск WebDAV

RFC5789

Методы HTTP из RFC 5789: метод PATCH для HTTP

Атрибуты

rack_request [R]

Публичные методы класса

empty () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 59
def self.empty
  new({})
end
new (env) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 63
def initialize(env)
  super

  @rack_request = Rack::Request.new(env)

  @method            = nil
  @request_method    = nil
  @remote_ip         = nil
  @original_fullpath = nil
  @fullpath          = nil
  @ip                = nil
end
Вызывает метод суперкласса ActionDispatch::Http::URL::new

Публичные методы экземпляра

GET () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 400
def GET
  fetch_header("action_dispatch.request.query_parameters") do |k|
    encoding_template = Request::Utils::CustomParamEncoder.action_encoding_template(self, path_parameters[:controller], path_parameters[:action])
    rack_query_params = ActionDispatch::ParamBuilder.from_query_string(rack_request.query_string, encoding_template: encoding_template)

    set_header k, rack_query_params
  end
rescue ActionDispatch::ParamError => e
  raise ActionController::BadRequest.new("Invalid query parameters: #{e.message}")
end

Переопределяет метод GET из Rack для поддержки доступа без учёта регистра.

Также имеет псевдоним: query_parameters
POST () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 413
def POST
  fetch_header("action_dispatch.request.request_parameters") do
    encoding_template = Request::Utils::CustomParamEncoder.action_encoding_template(self, path_parameters[:controller], path_parameters[:action])

    param_list = nil
    pr = parse_formatted_parameters(params_parsers) do
      if param_list = request_parameters_list
        ActionDispatch::ParamBuilder.from_pairs(param_list, encoding_template: encoding_template)
      else
        # We're not using a version of Rack that provides raw form
        # pairs; we must use its hash (and thus post-process it below).
        fallback_request_parameters
      end
    end

    # If the request body was parsed by a custom parser like JSON
    # (and thus the above block was not run), we need to
    # post-process the result hash.
    if param_list.nil?
      pr = ActionDispatch::ParamBuilder.from_hash(pr, encoding_template: encoding_template)
    end

    self.request_parameters = pr
  end
rescue ActionDispatch::ParamError, EOFError => e
  raise ActionController::BadRequest.new("Invalid request parameters: #{e.message}")
end

Переопределяет метод POST из Rack для поддержки доступа без учёта регистра.

Также имеет псевдоним: request_parameters
authorization () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 465
def authorization
  get_header("HTTP_AUTHORIZATION")   ||
  get_header("X-HTTP_AUTHORIZATION") ||
  get_header("X_HTTP_AUTHORIZATION") ||
  get_header("REDIRECT_X_HTTP_AUTHORIZATION")
end

Возвращает заголовок авторизации независимо от того, был ли он указан непосредственно или через один из альтернативных прокси-заголовков.

body () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 362
def body
  if raw_post = get_header("RAW_POST_DATA")
    raw_post = (+raw_post).force_encoding(Encoding::BINARY)
    StringIO.new(raw_post)
  else
    body_stream
  end
end

Тело запроса представляет собой входной поток IO. Если переменная окружения RAW_POST_DATA уже задана, она оборачивается в StringIO.

commit_csrf_token () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 497
def commit_csrf_token
  controller_instance.commit_csrf_token(self) if controller_instance.respond_to?(:commit_csrf_token)
end
commit_flash () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 486
def commit_flash
end
content_length () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 297
def content_length
  return raw_post.bytesize if has_header?(TRANSFER_ENCODING)
  super.to_i
end

Возвращает длину содержимого запроса в виде целого числа.

Вызывает метод суперкласса
controller_class () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 87
def controller_class
  params = path_parameters
  params[:action] ||= "index"
  controller_class_for(params[:controller])
end
controller_class_for (name) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 93
def controller_class_for(name)
  if name
    controller_param = name.underscore
    const_name = controller_param.camelize << "Controller"
    begin
      const_name.constantize
    rescue NameError => error
      if error.missing_name == const_name || const_name.start_with?("#{error.missing_name}::")
        raise MissingController.new(error.message, error.name)
      else
        raise
      end
    end
  else
    PASS_NOT_FOUND
  end
end
form_data? () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 378
def form_data?
  FORM_DATA_MEDIA_TYPES.include?(media_type)
end

Определяет, содержит ли тело запроса данные формы, проверяя наличие в запросе Content-Type одного из следующих типов содержимого: application/x-www-form-urlencoded или multipart/form-data. Список типов содержимого для данных формы можно изменить с помощью массива FORM_DATA_MEDIA_TYPES.

Тело запроса не считается содержащим данные формы, если заголовок Content-Type не указан, а request_method равен POST.

fullpath () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 276
def fullpath
  @fullpath ||= super
end

Возвращает полный путь последнего запрошенного URL в виде String, включая параметры.

# get "/articles"
request.fullpath # => "/articles"

# get "/articles?page=2"
request.fullpath # => "/articles?page=2"
Вызывает метод суперкласса
headers () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 237
def headers
  @headers ||= Http::Headers.new(self)
end

Предоставляет доступ к HTTP-заголовкам запроса, например:

request.headers["Content-Type"] # => "text/plain"
http_auth_salt () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 203
def http_auth_salt
  get_header "action_dispatch.http_auth_salt"
end
ip () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 311
def ip
  @ip ||= super
end

Возвращает IP-адрес клиента в виде String.

Вызывает метод суперкласса
key? (key) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 114
def key?(key)
  has_header? key
end

Возвращает true, если запрос содержит заголовок, соответствующий указанному параметру key.

request.key? :ip_spoofing_check # => true
local? () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 473
def local?
  LOCALHOST.match?(remote_addr) && LOCALHOST.match?(remote_ip)
end

Возвращает true, если запрос поступил с localhost, 127.0.0.1 или ::1.

logger () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 482
def logger
  get_header("action_dispatch.logger")
end
media_type () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 292
def media_type
  content_mime_type&.to_s
end

MIME-тип запроса в виде String.

# get "/articles"
request.media_type # => "application/x-www-form-urlencoded"
method (*args) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 217
def method(*args)
  if args.empty?
    @method ||= check_method(
      get_header("rack.methodoverride.original_method") ||
      get_header("REQUEST_METHOD")
    )
  else
    super
  end
end

Возвращает исходное значение REQUEST_METHOD из окружения, даже если оно было переопределено промежуточным ПО. Дополнительные сведения см. в разделе request_method.

В целях отладки при вызове с аргументами этот метод обращается к Object#method

Вызывает метод суперкласса
method_symbol () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 230
def method_symbol
  HTTP_METHOD_LOOKUP[method]
end

Возвращает символьное представление метода method.

original_fullpath () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 265
def original_fullpath
  @original_fullpath ||= (get_header("ORIGINAL_FULLPATH") || fullpath)
end

Возвращает String с путём последнего запроса, включая его параметры.

# get '/foo'
request.original_fullpath # => '/foo'

# get '/foo?bar'
request.original_fullpath # => '/foo?bar'
original_url () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 284
def original_url
  base_url + original_fullpath
end

Возвращает исходный URL запроса в виде String.

# get "/articles?page=2"
request.original_url # => "http://www.example.com/articles?page=2"
query_parameters ()
Псевдоним для: GET
raw_post () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 353
def raw_post
  unless has_header? "RAW_POST_DATA"
    set_header("RAW_POST_DATA", read_body_stream)
  end
  get_header "RAW_POST_DATA"
end

Читает тело запроса. Это полезно для веб-служб, которым нужно работать непосредственно с необработанными запросами.

remote_ip () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 317
def remote_ip
  @remote_ip ||= (get_header("action_dispatch.remote_ip") || ip).to_s
end

Возвращает IP-адрес клиента в виде String, обычно задаваемый промежуточным ПО RemoteIp.

remote_ip= (remote_ip) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 321
def remote_ip=(remote_ip)
  @remote_ip = nil
  set_header "action_dispatch.remote_ip", remote_ip
end
request_id () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 336
def request_id
  get_header ACTION_DISPATCH_REQUEST_ID
end

Возвращает уникальный идентификатор запроса, который берётся либо из заголовка X-Request-Id, который может быть создан межсетевым экраном, балансировщиком нагрузки или веб-сервером, либо из промежуточного ПО RequestId (которое устанавливает переменную окружения action_dispatch.request_id).

Этот уникальный идентификатор полезен для отслеживания запроса от начала до конца при ведении журнала или отладке. Для этого используется переменная Rack, задаваемая промежуточным ПО ActionDispatch::RequestId.

Также имеет псевдоним: uuid
request_method () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 151
def request_method
  @request_method ||= check_method(super)
end

Возвращает метод HTTP, который должно видеть приложение. Если метод был переопределён промежуточным ПО (например, если запрос HEAD был преобразован в GET или для определения метода, который должно использовать приложение, был применён параметр _method), этот метод возвращает переопределённое значение, а не исходное.

Вызывает метод суперкласса
request_method_symbol () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 208
def request_method_symbol
  HTTP_METHOD_LOOKUP[request_method]
end

Возвращает символьное представление метода request_method.

request_parameters ()
Псевдоним для: POST
request_parameters= (params) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 477
def request_parameters=(params)
  raise if params.nil?
  set_header("action_dispatch.request.request_parameters", params)
end
request_parameters_list () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 442
def request_parameters_list
  # We don't use Rack's parse result, but we must call it so Rack
  # can populate the rack.request.* keys we need.
  rack_post = rack_request.POST

  if form_pairs = get_header("rack.request.form_pairs")
    # Multipart
    form_pairs
  elsif form_vars = get_header("rack.request.form_vars")
    # URL-encoded
    ActionDispatch::QueryParser.each_pair(form_vars)
  elsif rack_post && !rack_post.empty?
    # It was multipart, but Rack did not preserve a pair list
    # (probably too old). Flat parameter list is not available.
    nil
  else
    # No request body, or not a format Rack knows
    []
  end
end
reset_csrf_token () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 493
def reset_csrf_token
  controller_instance.reset_csrf_token(self) if controller_instance.respond_to?(:reset_csrf_token)
end
reset_session () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 386
def reset_session
  session.destroy
  reset_csrf_token
end
route_uri_pattern () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 159
def route_uri_pattern
  unless pattern = get_header("action_dispatch.route_uri_pattern")
    route = get_header("action_dispatch.route")
    return if route.nil?
    pattern = route.path.spec.to_s
    set_header("action_dispatch.route_uri_pattern", pattern)
  end
  pattern
end

Возвращает шаблон URI сопоставленного маршрута запроса, используя тот же формат, что и bin/rails routes:

request.route_uri_pattern # => "/:controller(/:action(/:id))(.:format)"
send_early_hints (links) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 254
def send_early_hints(links)
  env["rack.early_hints"]&.call(links)
end

Early Hints — это код состояния HTTP/2, который передаёт подсказки, помогающие клиенту начать подготовку к обработке окончательного ответа.

Если env содержит rack.early_hints, сервер поддерживает HTTP2 push для заголовков link.

Метод send_early_hints принимает хеш ссылок в следующем формате:

send_early_hints("link" => "</style.css>; rel=preload; as=style,</script.js>; rel=preload")

Если вы используете javascript_include_tag или stylesheet_link_tag, заголовки Early Hints включаются по умолчанию, если они поддерживаются.

server_software () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 347
def server_software
  (get_header("SERVER_SOFTWARE") && /^([a-zA-Z]+)/ =~ get_header("SERVER_SOFTWARE")) ? $1.downcase : nil
end

Возвращает название программного обеспечения HTTP-сервера в нижнем регистре.

session_options= (options) Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 395
def session_options=(options)
  Session::Options.set self, options
end
uuid ()
Псевдоним для: request_id
xhr? ()
Псевдоним для: xml_http_request?
xml_http_request? () Показать исходный код
# File actionpack/lib/action_dispatch/http/request.rb, line 305
def xml_http_request?
  /XMLHttpRequest/i.match?(get_header("HTTP_X_REQUESTED_WITH"))
end

Возвращает true, если заголовок X-Requested-With содержит «XMLHttpRequest» (без учёта регистра). В зависимости от выбранных библиотек и фреймворков JavaScript его может потребоваться добавить вручную.

Также имеет псевдоним: xhr?

© 2004–2021 David Heinemeier Hansson
Licensed under the MIT License.

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API