Spec-Zone.ru › Ruby 4.0
  1. URI::
  2. Generic

class URI::Generic

Родительский класс:
Object
Подключённые модули:
URI

Базовый класс для всех классов URI. Реализует общий синтаксис URI согласно RFC 2396.

Константы

COMPONENT

Array доступных компонентов для URI::Generic.

DEFAULT_PORT

Порт по умолчанию — nil для URI::Generic.

Атрибуты

fragment [R]

Возвращает компонент фрагмента URI.

URI("http://foo/bar/baz?search=FooBar#ponies").fragment #=> "ponies"
host [R]

Возвращает компонент хоста URI.

URI("http://foo/bar/baz").host #=> "foo"

Возвращает nil, если компонент хоста отсутствует.

URI("mailto:foo@example.org").host #=> nil

Компонент не содержит номер порта.

URI("http://foo:8080/bar/baz").host #=> "foo"

Поскольку в URI адреса IPv6 заключаются в квадратные скобки, этот метод возвращает адреса IPv6 в квадратных скобках. Такая форма не подходит для передачи методам сокетов, например TCPSocket.open. Если требуются имена хостов без скобок, используйте метод hostname.

URI("http://[::1]/bar/baz").host     #=> "[::1]"
URI("http://[::1]/bar/baz").hostname #=> "::1"
opaque [R]

Возвращает непрозрачную часть URI.

URI("mailto:foo@example.org").opaque #=> "foo@example.org"
URI("http://foo/bar/baz").opaque     #=> nil

Часть пути, в которой не используется косая черта «/». Путь обычно указывает на абсолютный путь или непрозрачную часть. (См. разделы 3 и 5.2 RFC 2396.)

path [R]

Возвращает компонент пути URI.

URI("http://foo/bar/baz").path #=> "/bar/baz"
port [R]

Возвращает компонент порта URI.

URI("http://foo/bar/baz").port      #=> 80
URI("http://foo:8080/bar/baz").port #=> 8080
query [R]

Возвращает компонент запроса URI.

URI("http://foo/bar/baz?search=FooBar").query #=> "search=FooBar"
scheme [R]

Возвращает компонент схемы URI.

URI("http://foo/bar/baz").scheme #=> "http"

Общедоступные методы класса

build (args) Показать исходный код
# File lib/uri/generic.rb, line 116
def self.build(args)
  if args.kind_of?(Array) &&
      args.size == ::URI::Generic::COMPONENT.size
    tmp = args.dup
  elsif args.kind_of?(Hash)
    tmp = ::URI::Generic::COMPONENT.collect do |c|
      if args.include?(c)
        args[c]
      else
        nil
      end
    end
  else
    component = self.component rescue ::URI::Generic::COMPONENT
    raise ArgumentError,
          "expected Array of or Hash of components of #{self} (#{component.join(', ')})"
  end

  tmp << nil
  tmp << true
  return self.new(*tmp)
end

Краткое описание

См. ::new.

Описание

Создаёт новый экземпляр URI::Generic из компонентов URI::Generic с проверкой. Компоненты: scheme, userinfo, host, port, registry, path, opaque, query и fragment. Аргументы можно передать в виде Array или Hash. Допустимые ключи хеша и порядок элементов массива см. в ::new.

build2 (args) Показать исходный код
# File lib/uri/generic.rb, line 78
def self.build2(args)
  begin
    return self.build(args)
  rescue InvalidComponentError
    if args.kind_of?(Array)
      return self.build(args.collect{|x|
        if x.is_a?(String)
          URI::RFC2396_PARSER.escape(x)
        else
          x
        end
      })
    elsif args.kind_of?(Hash)
      tmp = {}
      args.each do |key, value|
        tmp[key] = if value
            URI::RFC2396_PARSER.escape(value)
          else
            value
          end
      end
      return self.build(tmp)
    end
  end
end

Краткое описание

См. ::new.

Описание

Сначала пытается создать новый экземпляр URI::Generic с помощью URI::Generic::build. Однако, если возникает исключение URI::InvalidComponentError, метод URI::RFC2396_PARSER.escape экранирует все компоненты URI, после чего предпринимается повторная попытка.

component () Показать исходный код
# File lib/uri/generic.rb, line 57
def self.component
  self::COMPONENT
end

Компоненты URI в заданном порядке.

default_port () Показать исходный код
# File lib/uri/generic.rb, line 32
def self.default_port
  self::DEFAULT_PORT
end

Возвращает порт по умолчанию.

new (scheme, userinfo, host, port, registry, path, opaque, query, fragment, parser = DEFAULT_PARSER, arg_check = false) Показать исходный код
# File lib/uri/generic.rb, line 169
def initialize(scheme,
               userinfo, host, port, registry,
               path, opaque,
               query,
               fragment,
               parser = DEFAULT_PARSER,
               arg_check = false)
  @scheme = nil
  @user = nil
  @password = nil
  @host = nil
  @port = nil
  @path = nil
  @query = nil
  @opaque = nil
  @fragment = nil
  @parser = parser == DEFAULT_PARSER ? nil : parser

  if arg_check
    self.scheme = scheme
    self.hostname = host
    self.port = port
    self.userinfo = userinfo
    self.path = path
    self.query = query
    self.opaque = opaque
    self.fragment = fragment
  else
    self.set_scheme(scheme)
    self.set_host(host)
    self.set_port(port)
    self.set_userinfo(userinfo)
    self.set_path(path)
    self.query = query
    self.set_opaque(opaque)
    self.fragment=(fragment)
  end
  if registry
    raise InvalidURIError,
      "the scheme #{@scheme} does not accept registry part: #{registry} (or bad hostname?)"
  end

  @scheme&.freeze
  self.set_path('') if !@path && !@opaque # (see RFC2396 Section 5.2)
  self.set_port(self.default_port) if self.default_port && !@port
end

Аргументы

scheme

Схема протокола, например ‘http’, ‘ftp’, ‘mailto’ и т. д.

userinfo

Имя пользователя и пароль, например ‘sdmitry:bla’.

host

Имя хоста сервера.

port

Порт сервера.

registry

Реестр органов именования.

path

Путь на сервере.

opaque

Непрозрачная часть.

query

Данные запроса.

fragment

Часть URI после символа «#».

parser

Парсер для внутреннего использования [по умолчанию URI::DEFAULT_PARSER].

arg_check

Проверка аргументов [по умолчанию false].

Описание

Создаёт новый экземпляр URI::Generic из «общих» компонентов без проверки.

Открытые методы экземпляра

+ (oth)
Псевдоним для: merge
- (oth)
Псевдоним для: route_from
== (oth) Показать исходный код
# File lib/uri/generic.rb, line 1399
def ==(oth)
  if self.class == oth.class
    self.normalize.component_ary == oth.normalize.component_ary
  else
    false
  end
end

Сравнивает два URI.

absolute ()
Псевдоним для: absolute?
absolute? () Показать исходный код
# File lib/uri/generic.rb, line 987
def absolute?
  if @scheme
    true
  else
    false
  end
end

Возвращает true, если для URI указана схема (например, http:// или https://).

Также имеет псевдоним: absolute
authority () Показать исходный код
# File lib/uri/generic.rb, line 579
def authority
  return @user, @password, @host, @port if @user || @password || @host || @port
end

Возвращает информацию об authority (массив из пользователя, пароля, хоста и порта), если она задана. В противном случае возвращает nil.

coerce (oth) Показать исходный код
# File lib/uri/generic.rb, line 1478
def coerce(oth)
  case oth
  when String
    oth = parser.parse(oth)
  else
    super
  end

  return oth, self
end

Аргументы

v

URI или String

Описание

Пытается разобрать другой URI oth, возвращает [parsed_oth, self].

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.coerce("http://foo.com")
#=> [#<URI::HTTP http://foo.com>, #<URI::HTTP http://my.example.com>]
Вызывает метод суперкласса
component () Показать исходный код
# File lib/uri/generic.rb, line 313
def component
  self.class.component
end

Компоненты URI в указанном порядке.

decoded_password () Показать исходный код
# File lib/uri/generic.rb, line 589
def decoded_password
  URI.decode_uri_component(@password) if @password
end

Возвращает компонент пароля после декодирования URI.

decoded_user () Показать исходный код
# File lib/uri/generic.rb, line 584
def decoded_user
  URI.decode_uri_component(@user) if @user
end

Возвращает компонент пользователя после декодирования URI.

default_port () Показать исходный код
# File lib/uri/generic.rb, line 39
def default_port
  self.class.default_port
end

Возвращает порт по умолчанию.

eql? (oth) Показать исходный код
# File lib/uri/generic.rb, line 1413
def eql?(oth)
  self.class == oth.class &&
  parser == oth.parser &&
  self.component_ary.eql?(oth.component_ary)
end

Сравнивает с oth на предмет Hash.

find_proxy (env=ENV) Показать исходный код
# File lib/uri/generic.rb, line 1504
def find_proxy(env=ENV)
  raise BadURIError, "relative URI: #{self}" if self.relative?
  name = self.scheme.downcase + '_proxy'
  proxy_uri = nil
  if name == 'http_proxy' && env.include?('REQUEST_METHOD') # CGI?
    # HTTP_PROXY conflicts with *_proxy for proxy settings and
    # HTTP_* for header information in CGI.
    # So it should be careful to use it.
    pairs = env.reject {|k, v| /\Ahttp_proxy\z/i !~ k }
    case pairs.length
    when 0 # no proxy setting anyway.
      proxy_uri = nil
    when 1
      k, _ = pairs.shift
      if k == 'http_proxy' && env[k.upcase] == nil
        # http_proxy is safe to use because ENV is case sensitive.
        proxy_uri = env[name]
      else
        proxy_uri = nil
      end
    else # http_proxy is safe to use because ENV is case sensitive.
      proxy_uri = env.to_hash[name]
    end
    if !proxy_uri
      # Use CGI_HTTP_PROXY.  cf. libwww-perl.
      proxy_uri = env["CGI_#{name.upcase}"]
    end
  elsif name == 'http_proxy'
    if RUBY_ENGINE == 'jruby' && p_addr = ENV_JAVA['http.proxyHost']
      p_port = ENV_JAVA['http.proxyPort']
      if p_user = ENV_JAVA['http.proxyUser']
        p_pass = ENV_JAVA['http.proxyPass']
        proxy_uri = "http://#{p_user}:#{p_pass}@#{p_addr}:#{p_port}"
      else
        proxy_uri = "http://#{p_addr}:#{p_port}"
      end
    else
      unless proxy_uri = env[name]
        if proxy_uri = env[name.upcase]
          warn 'The environment variable HTTP_PROXY is discouraged.  Please use http_proxy instead.', uplevel: 1
        end
      end
    end
  else
    proxy_uri = env[name] || env[name.upcase]
  end

  if proxy_uri.nil? || proxy_uri.empty?
    return nil
  end

  if self.hostname
    begin
      addr = IPSocket.getaddress(self.hostname)
      return nil if /\A127\.|\A::1\z/ =~ addr
    rescue SocketError
    end
  end

  name = 'no_proxy'
  if no_proxy = env[name] || env[name.upcase]
    return nil unless URI::Generic.use_proxy?(self.hostname, addr, self.port, no_proxy)
  end
  URI.parse(proxy_uri)
end

Возвращает URI прокси. URI прокси извлекается из переменных окружения, таких как http_proxy, ftp_proxy, no_proxy и т. д. Если подходящего прокси нет, возвращается nil.

Если задан необязательный параметр env, он используется вместо ENV.

Также проверяются переменные с заглавными буквами (HTTP_PROXY, FTP_PROXY, NO_PROXY и т. д.).

Однако в среде CGI к http_proxy и HTTP_PROXY применяется особая обработка. Это связано с тем, что HTTP_PROXY может быть задан заголовком Proxy:. Поэтому HTTP_PROXY не используется. http_proxy также не используется, если переменные не чувствительны к регистру. Вместо него можно использовать CGI_HTTP_PROXY.

fragment= (v) Показать исходный код
# File lib/uri/generic.rb, line 944
def fragment=(v)
  return @fragment = nil unless v

  x = v.to_str
  v = x.dup if x.equal? v
  v.encode!(Encoding::UTF_8) rescue nil
  v.delete!("\t\r\n")
  v.force_encoding(Encoding::ASCII_8BIT)
  v.gsub!(/(?!%\h\h|[!-~])./n){'%%%02X' % $&.ord}
  v.force_encoding(Encoding::US_ASCII)
  @fragment = v
end

Проверяет компонент fragment v на соответствие parser Regexp для :FRAGMENT.

Аргументы

v

String

Описание

Открытый метод установки компонента fragment v (с проверкой).

Использование

require 'uri'

uri = URI.parse("http://my.example.com/?id=25#time=1305212049")
uri.fragment = "time=1305212086"
uri.to_s  #=> "http://my.example.com/?id=25#time=1305212086"
hash () Показать исходный код
# File lib/uri/generic.rb, line 1408
def hash
  self.component_ary.hash
end

Возвращает хеш-значение.

hierarchical? () Показать исходный код
# File lib/uri/generic.rb, line 976
def hierarchical?
  if @path
    true
  else
    false
  end
end

Возвращает true, если URI является иерархическим.

Описание

URI содержит компоненты, перечисленные слева направо в порядке убывания значимости; см. RFC3986 www.rfc-editor.org/rfc/rfc3986, раздел 1.2.3.

Использование

require 'uri'

uri = URI.parse("http://my.example.com/")
uri.hierarchical?
#=> true
uri = URI.parse("mailto:joe@example.com")
uri.hierarchical?
#=> false
host= (v) Показать исходный код
# File lib/uri/generic.rb, line 652
def host=(v)
  check_host(v)
  set_host(v)
  set_userinfo(nil)
  v
end

Аргументы

v

String

Описание

Открытый метод установки компонента host v (с проверкой).

См. также URI::Generic.check_host.

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.host = "foo.com"
uri.to_s  #=> "http://foo.com"
hostname () Показать исходный код
# File lib/uri/generic.rb, line 668
def hostname
  v = self.host
  v&.start_with?('[') && v.end_with?(']') ? v[1..-2] : v
end

Извлекает часть хоста из URI и снимает скобки с адресов IPv6.

Этот метод аналогичен URI::Generic#host, но из адресов IPv6 (и будущих IP-адресов) удаляются скобки.

uri = URI("http://[::1]/bar")
uri.hostname      #=> "::1"
uri.host          #=> "[::1]"
hostname= (v) Показать исходный код
# File lib/uri/generic.rb, line 685
def hostname=(v)
  v = "[#{v}]" if !(v&.start_with?('[') && v&.end_with?(']')) && v&.index(':')
  self.host = v
end

Задаёт часть хоста в URI значением аргумента, добавляя скобки для адресов IPv6.

Этот метод аналогичен URI::Generic#host=, но в качестве аргумента можно передать IPv6-адрес без скобок.

uri = URI("http://foo/bar")
uri.hostname = "::1"
uri.to_s  #=> "http://[::1]/bar"

Если аргумент похож на IPv6-адрес, он заключается в скобки.

merge (oth) Показать исходный код
# File lib/uri/generic.rb, line 1124
def merge(oth)
  rel = parser.__send__(:convert_to_uri, oth)

  if rel.absolute?
    #raise BadURIError, "both URI are absolute" if absolute?
    # hmm... should return oth for usability?
    return rel
  end

  unless self.absolute?
    raise BadURIError, "both URI are relative"
  end

  base = self.dup

  authority = rel.authority

  # RFC2396, Section 5.2, 2)
  if (rel.path.nil? || rel.path.empty?) && !authority && !rel.query
    base.fragment=(rel.fragment) if rel.fragment
    return base
  end

  base.query = nil
  base.fragment=(nil)

  # RFC2396, Section 5.2, 4)
  if authority
    base.set_authority(*authority)
    base.set_path(rel.path)
  elsif base.path && rel.path
    base.set_path(merge_path(base.path, rel.path))
  end

  # RFC2396, Section 5.2, 7)
  base.query = rel.query       if rel.query
  base.fragment=(rel.fragment) if rel.fragment

  return base
end

Аргументы

oth

URI или String

Описание

Объединяет два URI.

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.merge("/main.rbx?page=1")
# => "http://my.example.com/main.rbx?page=1"
Также имеет псевдоним: +
merge! (oth) Показать исходный код
# File lib/uri/generic.rb, line 1096
def merge!(oth)
  t = merge(oth)
  if self == t
    nil
  else
    replace!(t)
    self
  end
end

Аргументы

oth

URI или String

Описание

Изменяющая версия метода merge.

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.merge!("/main.rbx?page=1")
uri.to_s  # => "http://my.example.com/main.rbx?page=1"
normalize () Показать исходный код
# File lib/uri/generic.rb, line 1331
def normalize
  uri = dup
  uri.normalize!
  uri
end

Возвращает нормализованный URI.

require 'uri'

URI("HTTP://my.EXAMPLE.com").normalize
#=> #<URI::HTTP http://my.example.com/>

Здесь нормализация означает, что:

  • схема и хост преобразуются в нижний регистр;

  • пустой компонент пути заменяется на «/».

normalize! () Показать исходный код
# File lib/uri/generic.rb, line 1340
def normalize!
  if path&.empty?
    set_path('/')
  end
  if scheme && scheme != scheme.downcase
    set_scheme(self.scheme.downcase)
  end
  if host && host != host.downcase
    set_host(self.host.downcase)
  end
end

Изменяющая версия метода normalize.

opaque= (v) Показать исходный код
# File lib/uri/generic.rb, line 916
def opaque=(v)
  check_opaque(v)
  set_opaque(v)
  v
end

Аргументы

v

String

Описание

Открытый метод установки непрозрачного компонента v (с проверкой).

См. также URI::Generic.check_opaque.

parser () Показать исходный код
# File lib/uri/generic.rb, line 289
def parser
  if !defined?(@parser) || !@parser
    DEFAULT_PARSER
  else
    @parser || DEFAULT_PARSER
  end
end

Возвращает используемый парсер.

Если parser не определён, используется DEFAULT_PARSER.

password () Показать исходный код
# File lib/uri/generic.rb, line 573
def password
  @password
end

Возвращает компонент пароля (без декодирования URI).

password= (password) Показать исходный код
# File lib/uri/generic.rb, line 498
def password=(password)
  check_password(password)
  set_password(password)
  # returns password
end

Аргументы

v

String

Описание

Открытый метод установки компонента password (с проверкой).

См. также URI::Generic.check_password.

Использование

require 'uri'

uri = URI.parse("http://john:S3nsit1ve@my.example.com")
uri.password = "V3ry_S3nsit1ve"
uri.to_s  #=> "http://john:V3ry_S3nsit1ve@my.example.com"
path= (v) Показать исходный код
# File lib/uri/generic.rb, line 830
def path=(v)
  check_path(v)
  set_path(v)
  v
end

Аргументы

v

String

Описание

Открытый метод установки компонента пути v (с проверкой).

См. также URI::Generic.check_path.

Использование

require 'uri'

uri = URI.parse("http://my.example.com/pub/files")
uri.path = "/faq/"
uri.to_s  #=> "http://my.example.com/faq/"
port= (v) Показать исходный код
# File lib/uri/generic.rb, line 743
def port=(v)
  check_port(v)
  set_port(v)
  set_userinfo(nil)
  port
end

Аргументы

v

String

Описание

Открытый метод установки компонента порта v (с проверкой).

См. также URI::Generic.check_port.

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.port = 8080
uri.to_s  #=> "http://my.example.com:8080"
query= (v) Показать исходный код
# File lib/uri/generic.rb, line 854
def query=(v)
  return @query = nil unless v
  raise InvalidURIError, "query conflicts with opaque" if @opaque

  x = v.to_str
  v = x.dup if x.equal? v
  v.encode!(Encoding::UTF_8) rescue nil
  v.delete!("\t\r\n")
  v.force_encoding(Encoding::ASCII_8BIT)
  raise InvalidURIError, "invalid percent escape: #{$1}" if /(%\H\H)/n.match(v)
  v.gsub!(/(?!%\h\h|[!$-&(-;=?-_a-~])./n.freeze){'%%%02X' % $&.ord}
  v.force_encoding(Encoding::US_ASCII)
  @query = v
end

Аргументы

v

String

Описание

Открытый метод установки компонента запроса v.

Использование

require 'uri'

uri = URI.parse("http://my.example.com/?id=25")
uri.query = "id=1"
uri.to_s  #=> "http://my.example.com/?id=1"
relative? () Показать исходный код
# File lib/uri/generic.rb, line 999
def relative?
  !absolute?
end

Возвращает true, если для URI не указана схема (например, http:// или https://).

route_from (oth) Показать исходный код
# File lib/uri/generic.rb, line 1274
def route_from(oth)
  # you can modify `rel', but cannot `oth'.
  begin
    oth, rel = route_from0(oth)
  rescue
    raise $!.class, $!.message
  end
  if oth == rel
    return rel
  end

  rel.set_path(route_from_path(oth.path, self.path))
  if rel.path == './' && self.query
    # "./?foo" -> "?foo"
    rel.set_path('')
  end

  return rel
end

Аргументы

oth

URI или String

Описание

Вычисляет относительный путь от oth к self.

Использование

require 'uri'

uri = URI.parse('http://my.example.com/main.rbx?page=1')
uri.route_from('http://my.example.com')
#=> #<URI::Generic /main.rbx?page=1>
Также имеет псевдоним: -
route_to (oth) Показать исходный код
# File lib/uri/generic.rb, line 1314
def route_to(oth)
  parser.__send__(:convert_to_uri, oth).route_from(self)
end

Аргументы

oth

URI или String

Описание

Вычисляет относительный путь от self к oth.

Использование

require 'uri'

uri = URI.parse('http://my.example.com')
uri.route_to('http://my.example.com/main.rbx?page=1')
#=> #<URI::Generic /main.rbx?page=1>
scheme= (v) Показать исходный код
# File lib/uri/generic.rb, line 360
def scheme=(v)
  check_scheme(v)
  set_scheme(v)
  v
end

Аргументы

v

String

Описание

Открытый метод установки компонента схемы v (с проверкой).

См. также URI::Generic.check_scheme.

Использование

require 'uri'

uri = URI.parse("http://my.example.com")
uri.scheme = "https"
uri.to_s  #=> "https://my.example.com"
select (*components) Показать исходный код
# File lib/uri/generic.rb, line 1444
def select(*components)
  components.collect do |c|
    if component.include?(c)
      self.__send__(c)
    else
      raise ArgumentError,
        "expected of components of #{self.class} (#{self.class.component.join(', ')})"
    end
  end
end

Аргументы

components

Несколько аргументов типа Symbol, определённых в URI::HTTP.

Описание

Выбирает указанные компоненты из URI.

Использование

require 'uri'

uri = URI.parse('http://myuser:mypass@my.example.com/test.rbx')
uri.select(:userinfo, :host, :path)
# => ["myuser:mypass", "my.example.com", "/test.rbx"]
to_s () Показать исходный код
# File lib/uri/generic.rb, line 1355
def to_s
  str = ''.dup
  if @scheme
    str << @scheme
    str << ':'
  end

  if @opaque
    str << @opaque
  else
    if @host || %w[file postgres].include?(@scheme)
      str << '//'
    end
    if self.userinfo
      str << self.userinfo
      str << '@'
    end
    if @host
      str << @host
    end
    if @port && @port != self.default_port
      str << ':'
      str << @port.to_s
    end
    if (@host || @port) && !@path.empty? && !@path.start_with?('/')
      str << '/'
    end
    str << @path
    if @query
      str << '?'
      str << @query
    end
  end
  if @fragment
    str << '#'
    str << @fragment
  end
  str
end

Создаёт String из URI.

Также имеет псевдоним: to_str
to_str ()
Псевдоним для: to_s
user () Показать исходный код
# File lib/uri/generic.rb, line 568
def user
  @user
end

Возвращает компонент пользователя (без декодирования URI).

user= (user) Показать исходный код
# File lib/uri/generic.rb, line 471
def user=(user)
  check_user(user)
  set_user(user)
  # returns user
end

Аргументы

v

String

Описание

Открытый метод установки компонента user (с проверкой).

См. также URI::Generic.check_user.

Использование

require 'uri'

uri = URI.parse("http://john:S3nsit1ve@my.example.com")
uri.user = "sam"
uri.to_s  #=> "http://sam@my.example.com"
userinfo () Показать исходный код
# File lib/uri/generic.rb, line 557
def userinfo
  if @user.nil?
    nil
  elsif @password.nil?
    @user
  else
    @user + ':' + @password
  end
end

Возвращает userinfo в виде «user» или «user:password».

userinfo= (userinfo) Показать исходный код
# File lib/uri/generic.rb, line 441
def userinfo=(userinfo)
  if userinfo.nil?
    return nil
  end
  check_userinfo(*userinfo)
  set_userinfo(*userinfo)
  # returns userinfo
end

Задаёт userinfo; аргумент представляет собой строку вида «name:pass».

Защищённые методы экземпляра

component_ary () Показать исходный код
# File lib/uri/generic.rb, line 1420
def component_ary
  component.collect do |x|
    self.__send__(x)
  end
end

Возвращает Array компонентов, определённых из COMPONENT Array.

set_authority (user, password, host, port = nil) Показать исходный код
# File lib/uri/generic.rb, line 627
          def set_authority(user, password, host, port = nil)
  @user, @password, @host, @port = user, password, host, port || self.default_port
end

Защищённый метод задания информации authority (user, password, host и port). Если port — nil, будет задан default_port.

set_host (v) Показать исходный код
# File lib/uri/generic.rb, line 619
def set_host(v)
  @host = v
end

Защищённый метод задания компонента host v.

См. также URI::Generic.host=.

set_opaque (v) Показать исходный код
# File lib/uri/generic.rb, line 898
def set_opaque(v)
  @opaque = v
end

Защищённый метод задания непрозрачного компонента v.

См. также URI::Generic.opaque=.

set_password (v) Показать исходный код
# File lib/uri/generic.rb, line 534
def set_password(v)
  @password = v
  # returns v
end

Защищённый метод задания компонента password v.

См. также URI::Generic.password=.

set_path (v) Показать исходный код
# File lib/uri/generic.rb, line 804
def set_path(v)
  @path = v
end

Защищённый метод задания компонента path v.

См. также URI::Generic.path=.

set_port (v) Показать исходный код
# File lib/uri/generic.rb, line 716
def set_port(v)
  v = v.empty? ? nil : v.to_i unless !v || v.kind_of?(Integer)
  @port = v
end

Защищённый метод задания компонента port v.

См. также URI::Generic.port=.

set_scheme (v) Показать исходный код
# File lib/uri/generic.rb, line 334
def set_scheme(v)
  @scheme = v&.downcase
end

Защищённый метод задания компонента scheme v.

См. также URI::Generic.scheme=.

set_user (v) Показать исходный код
# File lib/uri/generic.rb, line 524
def set_user(v)
  set_userinfo(v, nil)
  v
end

Защищённый метод задания компонента user v.

См. также URI::Generic.user=.

set_userinfo (user, password = nil) Показать исходный код
# File lib/uri/generic.rb, line 509
def set_userinfo(user, password = nil)
  unless password
    user, password = split_userinfo(user)
  end
  @user     = user
  @password = password

  [@user, @password]
end

Защищённый метод задания компонента user и password, если доступен (с проверкой).

См. также URI::Generic.userinfo=.

Приватные методы экземпляра

check_host (v) Показать исходный код
# File lib/uri/generic.rb, line 600
def check_host(v)
  return v unless v

  if @opaque
    raise InvalidURIError,
      "cannot set host with registry or opaque"
  elsif parser.regexp[:HOST] !~ v
    raise InvalidComponentError,
      "bad component(expected host component): #{v}"
  end

  return true
end

Проверяет компонент host v на соответствие RFC2396 и шаблону parser Regexp для :HOST.

Если задан компонент host, компоненты registry и opaque задавать нельзя.

check_opaque (v) Показать исходный код
# File lib/uri/generic.rb, line 876
def check_opaque(v)
  return v unless v

  # raise if both hier and opaque are not nil, because:
  # absoluteURI   = scheme ":" ( hier_part | opaque_part )
  # hier_part     = ( net_path | abs_path ) [ "?" query ]
  if @host || @port || @user || @path  # userinfo = @user + ':' + @password
    raise InvalidURIError,
      "cannot set opaque with host, port, userinfo or path"
  elsif v && parser.regexp[:OPAQUE] !~ v
    raise InvalidComponentError,
      "bad component(expected opaque component): #{v}"
  end

  return true
end

Проверяет непрозрачный компонент v на соответствие RFC2396 и шаблону parser Regexp для :OPAQUE.

Если задан непрозрачный компонент, компоненты host, port, user и path задавать нельзя.

check_password (v, user = @user) Показать исходный код
# File lib/uri/generic.rb, line 417
def check_password(v, user = @user)
  if @opaque
    raise InvalidURIError,
      "cannot set password with opaque"
  end
  return v unless v

  if !user
    raise InvalidURIError,
      "password component depends user component"
  end

  if parser.regexp[:USERINFO] !~ v
    raise InvalidComponentError,
      "bad password component"
  end

  return true
end

Проверяет компонент password v на соответствие RFC2396 и шаблону parser Regexp для :USERINFO.

Если задан компонент user, компонент registry или opaque задавать нельзя.

check_path (v) Показать исходный код
# File lib/uri/generic.rb, line 772
def check_path(v)
  # raise if both hier and opaque are not nil, because:
  # absoluteURI   = scheme ":" ( hier_part | opaque_part )
  # hier_part     = ( net_path | abs_path ) [ "?" query ]
  if v && @opaque
    raise InvalidURIError,
      "path conflicts with opaque"
  end

  # If scheme is ftp, path may be relative.
  # See RFC 1738 section 3.2.2, and RFC 2396.
  if @scheme && @scheme != "ftp"
    if v && v != '' && parser.regexp[:ABS_PATH] !~ v
      raise InvalidComponentError,
        "bad component(expected absolute path component): #{v}"
    end
  else
    if v && v != '' && parser.regexp[:ABS_PATH] !~ v &&
       parser.regexp[:REL_PATH] !~ v
      raise InvalidComponentError,
        "bad component(expected relative path component): #{v}"
    end
  end

  return true
end

Проверяет компонент path v на соответствие RFC2396 и шаблону parser Regexp для :ABS_PATH и :REL_PATH.

Если задан компонент path, непрозрачный компонент задавать нельзя.

check_port (v) Показать исходный код
# File lib/uri/generic.rb, line 697
def check_port(v)
  return v unless v

  if @opaque
    raise InvalidURIError,
      "cannot set port with registry or opaque"
  elsif !v.kind_of?(Integer) && parser.regexp[:PORT] !~ v
    raise InvalidComponentError,
      "bad component(expected port component): #{v.inspect}"
  end

  return true
end

Проверяет компонент port v на соответствие RFC2396 и шаблону parser Regexp для :PORT.

Если задан компонент port, компоненты registry и opaque задавать нельзя.

check_scheme (v) Показать исходный код
# File lib/uri/generic.rb, line 320
def check_scheme(v)
  if v && parser.regexp[:SCHEME] !~ v
    raise InvalidComponentError,
      "bad component(expected scheme component): #{v}"
  end

  return true
end

Проверяет компонент scheme v на соответствие шаблону parser Regexp для :SCHEME.

check_user (v) Показать исходный код
# File lib/uri/generic.rb, line 393
def check_user(v)
  if @opaque
    raise InvalidURIError,
      "cannot set user with opaque"
  end

  return v unless v

  if parser.regexp[:USERINFO] !~ v
    raise InvalidComponentError,
      "bad component(expected userinfo component or user component): #{v}"
  end

  return true
end

Проверяет компонент user v на соответствие RFC2396 и шаблону parser Regexp для :USERINFO.

Если задан компонент user, компоненты registry и opaque задавать нельзя.

check_userinfo (user, password = nil) Показать исходный код
# File lib/uri/generic.rb, line 375
def check_userinfo(user, password = nil)
  if !password
    user, password = split_userinfo(user)
  end
  check_user(user)
  check_password(password, user)

  return true
end

Проверяет user и password.

Если password не задан, то user разбивается с помощью URI::Generic.split_userinfo, чтобы извлечь user и +password.

См. также URI::Generic.check_user, URI::Generic.check_password.

escape_userpass (v) Показать исходный код
# File lib/uri/generic.rb, line 551
def escape_userpass(v)
  parser.escape(v, /[@:\/]/o) # RFC 1738 section 3.1 #/
end

Экранирует «user:password» v согласно разделу 3.1 RFC 1738.

merge_path (base, rel) Показать исходный код
# File lib/uri/generic.rb, line 1015
def merge_path(base, rel)

  # RFC2396, Section 5.2, 5)
  # RFC2396, Section 5.2, 6)
  base_path = split_path(base)
  rel_path  = split_path(rel)

  # RFC2396, Section 5.2, 6), a)
  base_path << '' if base_path.last == '..'
  while i = base_path.index('..')
    base_path.slice!(i - 1, 2)
  end

  if (first = rel_path.first) and first.empty?
    base_path.clear
    rel_path.shift
  end

  # RFC2396, Section 5.2, 6), c)
  # RFC2396, Section 5.2, 6), d)
  rel_path.push('') if rel_path.last == '.' || rel_path.last == '..'
  rel_path.delete('.')

  # RFC2396, Section 5.2, 6), e)
  tmp = []
  rel_path.each do |x|
    if x == '..' &&
        !(tmp.empty? || tmp.last == '..')
      tmp.pop
    else
      tmp << x
    end
  end

  add_trailer_slash = !tmp.empty?
  if base_path.empty?
    base_path = [''] # keep '/' for root directory
  elsif add_trailer_slash
    base_path.pop
  end
  while x = tmp.shift
    if x == '..'
      # RFC2396, Section 4
      # a .. or . in an absolute path has no special meaning
      base_path.pop if base_path.size > 1
    else
      # if x == '..'
      #   valid absolute (but abnormal) path "/../..."
      # else
      #   valid absolute path
      # end
      base_path << x
      tmp.each {|t| base_path << t}
      add_trailer_slash = false
      break
    end
  end
  base_path.push('') if add_trailer_slash

  return base_path.join('/')
end

Объединяет базовый путь base с относительным путём rel и возвращает изменённый базовый путь.

replace! (oth) Показать исходный код
# File lib/uri/generic.rb, line 299
def replace!(oth)
  if self.class != oth.class
    raise ArgumentError, "expected #{self.class} object"
  end

  component.each do |c|
    self.__send__("#{c}=", oth.__send__(c))
  end
end

Заменяет текущий объект другим объектом URI.

split_path (path) Показать исходный код
# File lib/uri/generic.rb, line 1006
def split_path(path)
  path.split("/", -1)
end

Возвращает Array частей пути, разделённых символом «/».

split_userinfo (ui) Показать исходный код
# File lib/uri/generic.rb, line 542
def split_userinfo(ui)
  return nil, nil unless ui
  user, password = ui.split(':', 2)

  return user, password
end

Возвращает userinfo ui как [user, password], если оно правильно отформатировано в виде «user:password».

Ruby Core © 1993–2025 Yukihiro Matsumoto
Licensed under the Ruby License.
Ruby Standard Library © contributors
Licensed under their own licenses.

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API